Closed Bug 477419 Opened 12 years ago Closed 10 years ago

Message List Goes Blank After Folders Compacted

Categories

(MailNews Core :: Backend, defect)

1.8 Branch
x86
Windows XP
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: robert.stewart, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: version 2.0.0.19 (20081209)

The message list disappears during and following an automatic folder compaction operation.  I will watch to see if this recurs.

Reproducible: Didn't try

Steps to Reproduce:
1. Configure the Junk Privacy settings so marking messages as Junk deletes
them.
2. Configure the Network & Disk Space Advanced setting to compact folders when
it will save a small amount of space.
3. Select a message in the Inbox list. The message appears in the view pane.
4. Click the Junk icon in the Inbox list for that message.
5. Repeat until folder compaction runs.
Actual Results:  
The message is deleted, the next message appears in the view pane, and folder compaction begins.  Once compaction begins, the message list disappears (and the scroll bar with it).  When compaction ends, the newly selected message is still visible, but the message list is not redisplayed.

Expected Results:  
The message list should be visible once compaction ends.  Better yet, it should remain visible but greyed out during compaction and then reenabled when compaction ends.

My Inbox message list was long enough to require a scroll bar (in case that is important).

This is very similar to bug 397137 which I think was fixed, though now I wonder if I just haven't seen it recently.
Version: unspecified → 2.0
Today, just after a restart, I did the same thing, but TB behaved correctly.  The message list remained visible the whole time and was still visible and fully functional immediately after.  I'll keep an eye on this to see if I notice anything else that has bearing.
Component: Mail Window Front End → Backend
Product: Thunderbird → MailNews Core
QA Contact: front-end → backend
Version: 2.0 → 1.8 Branch
Severity: normal → minor
Whiteboard: dupeme
WFM per comment 1
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.