Last Comment Bug 477528 - Replace [amp]image to [amp]#8465;
: Replace [amp]image to [amp]#8465;
Status: RESOLVED FIXED
[fixed by the HTML5 parser]
:
Product: Core
Classification: Components
Component: HTML: Parser (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: mozilla2.0
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: html5-parsing
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-08 16:23 PST by Vitaliy Skorobagatko
Modified: 2011-09-05 22:32 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
reporter's testcase (193 bytes, text/html)
2011-09-05 16:09 PDT, David Baron :dbaron: ⌚️UTC-7 (busy September 14-25)
no flags Details

Description Vitaliy Skorobagatko 2009-02-08 16:23:02 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6

http://example.com/?param=val&image=bug
Look at the link in Firefox

Reproducible: Always
Comment 1 Tyler Downer [:Tyler] 2010-10-06 14:23:33 PDT
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Comment 2 Tyler Downer [:Tyler] 2010-11-01 22:56:05 PDT
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Comment 3 Vitaliy Skorobagatko 2010-11-02 01:15:46 PDT
In Firefox 3.6.12, this symbol can be seen up to now.

test.html
<pre>
text text text text text text text text text text text text text text
http://example.com/?param=val&image=bug
text text text text text text text text text text text text text text
</pre>

Should be:
http://example.com/?param=val&image=bug

A visible:
http://example.com/?param=valℑ=bug

Occurs some change &image=
Comment 4 Nickolay_Ponomarev 2010-11-27 12:00:31 PST
Interesting, I see this in Firefox 3.6, but not in the latest Firefox 4 build. Can you still reproduce using a build from <http://nightly.mozilla.org/>?
Comment 5 Tim (fmdeveloper) 2011-06-26 02:00:20 PDT
Reporter -> Are you still experiencing this issue with the latest version of Firefox 5? (comment 4 seems to point to this being fixed)
Comment 6 Tim (fmdeveloper) 2011-08-06 15:29:52 PDT
Looks to still be an issue with Mozilla/5.0 (Windows NT 5.1; rv:8.0a1) Gecko/20110802 Firefox/8.0a1 ID:20110802030845
Comment 7 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2011-09-05 16:09:17 PDT
Created attachment 558359 [details]
reporter's testcase
Comment 8 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2011-09-05 16:16:56 PDT
Fixed between 3.6 and 4.0, almost certainly by the HTML5 parser.

Note You need to log in before you can comment on or make changes to this bug.