Last Comment Bug 477552 - Zooming on planet.ubuntu.com creates weird gray lines
: Zooming on planet.ubuntu.com creates weird gray lines
Status: RESOLVED DUPLICATE of bug 468496
: regression
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: x86 Linux
: P3 normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
http://planet.ubuntu.com/
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-08 21:45 PST by Daniel Holbert [:dholbert]
Modified: 2009-10-19 10:30 PDT (History)
8 users (show)
roc: wanted1.9.1+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
screenshot of bug on planet.ubuntu.com (153.93 KB, image/png)
2009-02-08 21:45 PST, Daniel Holbert [:dholbert]
no flags Details
reduced test case (582 bytes, text/html)
2009-02-09 16:16 PST, Zack Weinberg (:zwol)
no flags Details
testcase 1 (295 bytes, text/html)
2009-02-09 16:44 PST, Daniel Holbert [:dholbert]
no flags Details
demo that EXTEND_PAD solves the problem (2.86 KB, patch)
2009-02-09 18:42 PST, Zack Weinberg (:zwol)
no flags Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] 2009-02-08 21:45:44 PST
Created attachment 361220 [details]
screenshot of bug on planet.ubuntu.com

STR:
 1. Visit http://planet.ubuntu.com/
 2. Zoom out (Ctrl -)

ACTUAL RESULTS:  Weird gray lines appear in various places (see screenshot)
EXPECTED RESULTS: No weird gray lines.

Broken on mozilla-central and 1.9.1 branch.  Tested these builds:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090208 Minefield/3.2a1pre
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20090203 Shiretoko/3.1b3pre

But, working in Firefox 3.0.5:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121622 Ubuntu/8.10 (intrepid) Firefox/3.0.5

Requesting blocking status, as this is a regression in 3.1 with respect to 3.0.
Comment 1 Daniel Holbert [:dholbert] 2009-02-08 21:48:32 PST
FWIW, I get gray lines when zooming in, too.

Almost all zoomlevels (aside from 1.0x) give me weird gray lines *somewhere*, though the lines' location varies depending on the zoomlevel.
Comment 2 Robert O'Callahan (:roc) (email my personal email if necessary) 2009-02-09 15:33:42 PST
Linux only? Seems to WFM on Mac.

Definitely need a regression window and a reduced testcase.
Comment 3 Zack Weinberg (:zwol) 2009-02-09 16:16:35 PST
Created attachment 361406 [details]
reduced test case

I see it on Linux & I'm willing to bet it's bug 468496 (i.e. yet another place where it matters that we aren't using CAIRO_EXTEND_PAD).  Reduced self-contained test case attached.  (One of) the problem images is embedded; it'll be at the far right of the window.  Scale the page up and down and you should see gray or black lines at its edges.
Comment 4 Daniel Holbert [:dholbert] 2009-02-09 16:44:04 PST
Created attachment 361413 [details]
testcase 1

On planet.ubuntu.com, it seems the gray lines appear on the edges of of the "chat bubble" PNG images, which are displayed via the CSS "background:" property.

Here's a reduced testcase, using a mozilla PNG image to display the same problem.  I see gray or black lines on the bottom & right edges of the 300x300 div in this testcase at these zoomlevels:
  Zoomed out 1x
  Zoomed out 7x (that's the max that it lets you zoom out, btw)

  Zoomed in 3x
  Zoomed in 13x

(where "zoomed out/in [N]x" means to start at default zoomlevel, hold ctrl, and press - or + N times)
Comment 5 Zack Weinberg (:zwol) 2009-02-09 16:59:40 PST
Yup, I can see lines at the bottom & right edges of the image on my computer too, but at different zoomlevels:

  zoomed out 1x (gray)
  zoomed out 3x (black)
  zoomed out 5x (black) (it won't let me zoom out any farther than this)

  zoomed in 3x, 13x (black) (*only if* zooming is done with the scroll wheel, not with Ctrl-+ -- it looks like Ctrl-+ takes bigger steps)
Comment 6 Daniel Holbert [:dholbert] 2009-02-09 17:00:58 PST
(In reply to comment #5)
>   zoomed in 3x, 13x (black) (*only if* zooming is done with the scroll wheel,

Oh, sorry -- I was in fact using the scroll wheel when making my counts in comment 4. :)  I assumed the steps were the same, but I guess they aren't.
Comment 7 Robert O'Callahan (:roc) (email my personal email if necessary) 2009-02-09 17:41:42 PST
Should be able to test the EXTEND_PAD hypothesis by hacking it in and seeing what happens, assuming EXTEND_PAD actually works on your system...
Comment 8 Zack Weinberg (:zwol) 2009-02-09 18:42:10 PST
Created attachment 361449 [details] [diff] [review]
demo that EXTEND_PAD solves the problem

Indeed, the attached patch makes the problem disappear for me on both test cases and on planet.ubuntu.com.  However, it is also visibly very slow.
Comment 9 Zack Weinberg (:zwol) 2009-02-09 18:43:34 PST
Comment on attachment 361449 [details] [diff] [review]
demo that EXTEND_PAD solves the problem

clarifying title.  ALso, please ignore the changes to reftests/border-image/reftest.list in the patch, I forgot I had some other changes in my tree.
Comment 10 Robert O'Callahan (:roc) (email my personal email if necessary) 2009-02-09 19:05:17 PST
I'd still like to know the regression range, but I suspect this is going to end up in the "X drivers suck" department.
Comment 11 Zack Weinberg (:zwol) 2009-02-09 20:20:33 PST
I have an idea, which I shall describe in bug 468496 later.  Need to finish up some other stuff first.
Comment 12 Daniel Holbert [:dholbert] 2009-02-13 16:43:05 PST
FWIW: I can actually reproduce the bug by viewing a PNG image directly (e.g. http://www.mozilla.org/images/front-moz-store.png ) and then simply zooming that.  No need to use "background: url()" after all.
Comment 13 Daniel Holbert [:dholbert] 2009-03-10 12:07:44 PDT
Related to bug 467832?
Comment 14 Sylvain Pasche 2009-05-01 17:09:15 PDT
Same regression range as bug 487996 (probable fallout from bug 458487).
Comment 15 Daniel Holbert [:dholbert] 2009-06-19 11:13:31 PDT
*** Bug 499308 has been marked as a duplicate of this bug. ***
Comment 16 Daniel Holbert [:dholbert] 2009-06-19 11:14:31 PDT
*** Bug 467832 has been marked as a duplicate of this bug. ***
Comment 17 Robert O'Callahan (:roc) (email my personal email if necessary) 2009-07-07 12:57:33 PDT
Duplicate of bug 468496 indicated by comment #8.

*** This bug has been marked as a duplicate of bug 468496 ***

Note You need to log in before you can comment on or make changes to this bug.