Closed Bug 477867 Opened 16 years ago Closed 7 years ago

unit tests don't rebuild when I change a header they depend on

Categories

(Firefox Build System :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: dbaron, Unassigned)

Details

When I change TestHarness.h, the unit tests in xpcom/tests don't rebuild when I run make in xpcom/tests.  However, if I explicitly make the .o file, it rebuilds due to the change, and then make will rebuild the binary from the .o, which is odd, since it makes it seem like all needed dependencies are present.

Steps to reproduce:
  build a full tree 
  cd $objdir/xpcom/tests
  touch $srcdir/xpcom/tests/TestHarness.h
  make
    [nothing happens; this is the bug]
  make TestPipe.o
    [TestPipe.o gets rebuilt]
  make
    [TestPipe gets rebuilt]
  
Note that |make TestPipe.o| only rebuilds TestPipe.o if TestHarness.h (or, presumably, some other dependency) was touched since the last rebuild.
This should have gotten fixed with all the binaries dependency work over the past few years.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.