fix uninitialized memory read in nsScreenManager shutdown

RESOLVED FIXED in mozilla1.9.2a1

Status

()

Core
Widget: Gtk
P3
normal
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: dbaron, Assigned: dbaron)

Tracking

({valgrind})

Trunk
mozilla1.9.2a1
All
Linux
valgrind
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
Created attachment 361711 [details] [diff] [review]
patch

I noticed a valgrind warning recently when shutting down:  we're reading unitialized memory in nsScreenManager.  The problem is that numScreens is uninitialized in some cases.  This patch fixes the problem by only changing mXineramaIsActive from its initial false value when numScreens is initialized.
Attachment #361711 - Flags: superreview?(roc)
Attachment #361711 - Flags: review?(roc)
Attachment #361711 - Flags: superreview?(roc)
Attachment #361711 - Flags: superreview+
Attachment #361711 - Flags: review?(roc)
Attachment #361711 - Flags: review+

Updated

9 years ago
Flags: in-testsuite+
Keywords: valgrind
(Assignee)

Comment 1

9 years ago
http://hg.mozilla.org/mozilla-central/rev/e267c6e75012
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Priority: -- → P3
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.