startup crash in [@ xul.dll!ConvertColormap]

VERIFIED INVALID

Status

--
critical
VERIFIED INVALID
10 years ago
7 years ago

People

(Reporter: dougt, Unassigned)

Tracking

({crash})

Trunk
x86
Windows Mobile 6 Professional
crash

Details

(crash signature)

(Reporter)

Description

10 years ago
In a debug build on the 6.1 emulator, i am failing to start up and crashing instead with the following:


Undefined Instruction: Thread=96e12a94 Proc=80096c20 'xulrunner.exe'
AKY=00000401 PC=783c9948(xul.dll+0x002c9948) RA=783c98b4(xul.dll+0x002c98b4) BVA
=f000ffcc FSR=00000409



>	xul.dll!ConvertColormap(unsigned int* aColormap = 0x00000000, unsigned int aColors = 4) Line: 711, Byte Offsets: 0xa4	C++
 	xul.dll!nsGIFDecoder2::GifWrite(const unsigned char* buf = 0x00000004, unsigned int len = 10066329) Line: 871, Byte Offsets: 0x344	C++
 	xul.dll!nsGIFDecoder2::ProcessData(unsigned char* data = 0x00000004, unsigned int count = 10066329, unsigned int* _retval = 0xffff00ff) Line: 250, Byte Offsets: 0x18	C++
 	xul.dll!ReadDataOut(nsIInputStream* in = 0x00000000, void* closure = 0x00000004, const char* fromRawSegment = 0x00999999, unsigned int toOffset = 4294902015, unsigned int count = 54, unsigned int* writeCount = 0x21baf35c) Line: 191, Byte Offsets: 0x20	C++
 	xul.dll!nsPipeInputStream::ReadSegments(unsigned int (nsIInputStream*, void*, const char*, unsigned int, unsigned int, unsigned int*)* writer = 0x00000000, void* closure = 0x00999999, unsigned int count = 4294902015, unsigned int* readCount = 0x21baf48c) Line: 799, Byte Offsets: 0x140	C++
 	xul.dll!nsGIFDecoder2::WriteFrom(nsIInputStream* inStr = 0x00000004, unsigned int count = 10066329, unsigned int* _retval = 0xffff00ff) Line: 274, Byte Offsets: 0x38	C++
 	xul.dll!imgRequest::OnDataAvailable(nsIRequest* aRequest = 0x00000004, nsISupports* ctxt = 0x00999999, nsIInputStream* inStr = 0xffff00ff, unsigned int sourceOffset = 0, unsigned int count = 54) Line: 940, Byte Offsets: 0x918	C++
 	xul.dll!ProxyListener::OnDataAvailable(nsIRequest* aRequest = 0x00000004, nsISupports* ctxt = 0x00999999, nsIInputStream* inStr = 0xffff00ff, unsigned int sourceOffset = 0, unsigned int count = 54) Line: 1417, Byte Offsets: 0x8c	C++
 	xul.dll!nsJARChannel::OnDataAvailable(nsIRequest* req = 0x00000004, nsISupports* ctx = 0x00999999, nsIInputStream* stream = 0xffff00ff, unsigned int offset = 0, unsigned int count = 54) Line: 877, Byte Offsets: 0xa0	C++
 	xul.dll!nsInputStreamPump::OnStateTransfer(void) Line: 508, Byte Offsets: 0x220	C++
 	xul.dll!nsInputStreamPump::OnInputStreamReady(nsIAsyncInputStream* stream = 0x00000004) Line: 399, Byte Offsets: 0x94	C++
 	xul.dll!nsInputStreamReadyEvent::Run(void) Line: 112, Byte Offsets: 0x68	C++
 	xul.dll!nsThread::ProcessNextEvent(int mayWait = 4, int* result = 0x00999999) Line: 511, Byte Offsets: 0x264	C++
 	xul.dll!NS_ProcessNextEvent_P(nsIThread* thread = 0x00000000, int mayWait = 4) Line: 230, Byte Offsets: 0x68	C++
 	xul.dll!nsBaseAppShell::Run(void) Line: 170, Byte Offsets: 0x70	C++
 	xul.dll!nsAppStartup::Run(void) Line: 193, Byte Offsets: 0x98	C++
 	xul.dll!XRE_main(int argc = 0, char** argv = 0x00000004, nsXREAppData* aAppData = 0x00999999) Line: 3216, Byte Offsets: 0x261c	C++
 	xulrunner.exe!NS_internal_main(int argc = 0, char** argv = 0x00000004) Line: 463, Byte Offsets: 0x98c	C++
 	xulrunner.exe!wmain(int argc = 0, wchar_t** argv = 0x00000004) Line: 107, Byte Offsets: 0x178	C++
 	xulrunner.exe!mainWCRTStartup(HINSTANCE__* hInstance = 0x00000000, HINSTANCE__* hInstancePrev = 0x00000004, unsigned short* lpszCmdLine = 0x00999999, int nCmdShow = -65281) Line: 188, Byte Offsets: 0x94	C++
(Reporter)

Comment 1

10 years ago
very possible ARMv6 code.

Updated

10 years ago
Severity: normal → critical
Keywords: crash
Summary: startup crash in xul.dll!ConvertColormap → startup crash in [@ xul.dll!ConvertColormap]
(Reporter)

Comment 2

10 years ago
this is running ARMv6 instructions on a ARMv4 emulator.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
ok, this is invalid.
Status: RESOLVED → VERIFIED

Comment 4

9 years ago
sorry for bug spam.
Many of the bugs which are marked invalid, I see comments telling it occurred in one version or other. But later it was fixed due to 1) by backingout the patch which made regression or 2) by fixing some other bug.
So if we can identify the bug/patch/reason then we should state that and mark those as FIXED. If not mark as WORKSFORME in that case.

Comment 5

9 years ago
Biju: don't spam. This bug is clearly actually invalid. The compiler generates armv6 code. The emulator only supports armv4 code. When the emulator encounters arm code >v4, the emulated app will crash, just as it would on a genuine armv4 processor.

We have many many bugs, some will be incorrectly categorized, but spamming them all will absolutely **** off the janitors involved in trying to keep bugzilla healthy. We do try to clear up resolutions when we can, and we don't really use invalid that often anymore.
(Assignee)

Updated

7 years ago
Crash Signature: [@ xul.dll!ConvertColormap]
You need to log in before you can comment on or make changes to this bug.