Incorrect font-weight for italic Helvetica Neue

RESOLVED DUPLICATE of bug 420981

Status

()

RESOLVED DUPLICATE of bug 420981
10 years ago
10 years ago

People

(Reporter: phiw2, Assigned: jtd)

Tracking

({regression, testcase})

Trunk
x86
Mac OS X
regression, testcase
Points:
---
Bug Flags:
blocking1.9.1 -
wanted1.9.1 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 361956 [details]
test case

given 
body {font: 300 1em/1.5 'Helvetica Neue', sans-serif; /*Helvetica neue light*/}
italicised text will use the ultra light face of Helvetica Neue, instead of the one with the same weight (in the example case: 'Helvetica neue light'.

In the testcase, italics for font-weight 100, 200 and 300 all use the ultralight face [1])

OK
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090112 Minefield/3.2a1pre
http://hg.mozilla.org/mozilla-central/rev/ca9d3c35fe47

fails
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090113 Minefield/3.2a1pre
http://hg.mozilla.org/mozilla-central/rev/9dbded90af2a

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ca9d3c35fe47&tochange=9dbded90af2a

--> bug 455243 I suspect (the other possibility is bug 465452)


[1]see bug 420981 for issue woth font-weight 100 and Helvetica Neue)
Flags: wanted1.9.1?
Flags: blocking1.9.1?
(Assignee)

Comment 1

10 years ago
This is a duplicate of bug 420981.  The testcase is different the underlying Apple bug is the same.  Apple keeps telling me it's "fixed in SL xxx" but it still hasn't been corrected, even in the latest seed.  Basically Cocoa tells us that the Light and UltraLight faces have the same weight.  So if you want to mark something as blocking, mark it on bug 420981 please.
(Reporter)

Comment 2

10 years ago
But this particular bug didn't happen until recently. Or did bug 455243 just make it visible ?

Before the 20090112 build (and 20090115 Shiretoko build), Helvetica Neue Light was used for both the normal font-style and the italic font-style. After that, UltraLight is used for font-style italic for for font-weight 100,200 and 300.
(Assignee)

Comment 3

10 years ago
(In reply to comment #2)
> But this particular bug didn't happen until recently. Or did bug 455243 just
> make it visible ?

Yeah, that must be what's happening.  Vlad put in a sort and that's probably subtly reordering things such that the behavior changed.  I'll take a look.
Assignee: nobody → jdaggett
Status: NEW → ASSIGNED
Not marking blocking as per comment #1 -- sounds like we just permuted the behaviour.
Flags: wanted1.9.1?
Flags: wanted1.9.1-
Flags: blocking1.9.1?
Flags: blocking1.9.1-
(Assignee)

Comment 5

10 years ago
Same problem as bug 420981, fixing there.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 420981
You need to log in before you can comment on or make changes to this bug.