vertical table margins not correctly applied if captions are present

RESOLVED FIXED

Status

()

RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: bernd_mozilla, Assigned: bernd_mozilla)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

10 years ago
Created attachment 362455 [details]
testcase

this is a CSS2.1 issue
(Assignee)

Comment 1

10 years ago
and the top margins of the table and the caption should collapse.
(Assignee)

Comment 2

10 years ago
Created attachment 362464 [details] [diff] [review]
patch
Assignee: nobody → bernd_mozilla
Status: NEW → ASSIGNED
(Assignee)

Comment 3

10 years ago
Created attachment 362485 [details] [diff] [review]
rev. patch
Attachment #362464 - Attachment is obsolete: true
(Assignee)

Updated

10 years ago
Attachment #362485 - Flags: superreview?(dbaron)
Attachment #362485 - Flags: review?(dbaron)

Comment 4

10 years ago
Hi Bernd, I came across this bug while working on bug 477462.

(In reply to comment #1)
> and the top margins of the table and the caption should collapse.

That's what the current CR says, but you don't take the Errata into account (boy, I'm happy the WG decided to publish a new CR soon..).

According to the errata, the anonymous block that includes the table and its caption is now a block formatting context. Another correction says that the outer vertical margins of a block formatting contexts do never collapse with margins of their in-flow children.

So caption margins should never collapse with table margins. This is possibly related to Bug 297676 which is based on an older version of the spec.
(Assignee)

Comment 5

10 years ago
Comment on attachment 362485 [details] [diff] [review]
rev. patch

http://www.w3.org/Style/css2-updates/CR-CSS21-20070719-errata.html

man, do I love changing specs!
Attachment #362485 - Flags: superreview?(dbaron)
Attachment #362485 - Flags: review?(dbaron)
(Assignee)

Comment 6

10 years ago
Created attachment 365511 [details] [diff] [review]
patch to incorporate the errata
Attachment #362485 - Attachment is obsolete: true
Attachment #365511 - Flags: superreview?
Attachment #365511 - Flags: review?
(Assignee)

Updated

10 years ago
Attachment #365511 - Flags: superreview?(dbaron)
Attachment #365511 - Flags: superreview?
Attachment #365511 - Flags: review?(dbaron)
Attachment #365511 - Flags: review?
(Assignee)

Comment 7

10 years ago
Robert do you have time to review this? Its a IE8, webkit, opera parity bug. MS has a test case that demonstrates our wrong behavior.
Attachment #365511 - Flags: superreview?(dbaron)
Attachment #365511 - Flags: superreview+
Attachment #365511 - Flags: review?(dbaron)
Attachment #365511 - Flags: review+
(Assignee)

Comment 8

10 years ago
http://hg.mozilla.org/mozilla-central/rev/b4b7eb4407c3
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Depends on: 501870
Duplicate of this bug: 563950
You need to log in before you can comment on or make changes to this bug.