Cannot build by VS2005 without VistaSDK (Cannot open include file: 'msctf.h': No such file or directory)

RESOLVED INVALID

Status

()

RESOLVED INVALID
10 years ago
3 years ago

People

(Reporter: masayuki, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---
Bug Flags:
blocking1.9.1 -

Firefox Tracking Flags

(Not tracked)

Details

VS2005 doesn't have msctf.h, it's included in Vista SDK. Therefore, we need to install Vista SDK for building by VS2005. However, it changes our build requirements. I'm not sure it should be so.

The header file is needed by TSF support. If we make a new build option, e.g., "--disable-tsf-support", we can keep the build requirements.

Note that we should disable TSF support by "--disable-vista-sdk-requirements", maybe. Because I couldn't build Fx by VS2005+Vista SDK without the option.
We should fix things so that people can get a working build without changing their .mozconfigs or installing a new SDK.
roc: We already require the Vista SDK. --disable-vista-sdk-requirements should be fixed to cover this case as well. Our policy is not to silently disable code that you can't build, but to make configure provide useful error messages telling you what you're missing and how to either install it, or disable the code that won't build.
OK then, so here we need to disable TSF if --disable-vista-sdk-requirements is set.
(In reply to comment #0)
> Note that we should disable TSF support by "--disable-vista-sdk-requirements",
> maybe. Because I couldn't build Fx by VS2005+Vista SDK without the option.

Oops, I meant we should *not* disable TSF support by "--disable-vista-sdk-requirements".

I installed Vista SDK to my WinXP with VS2005. But I could not build Fx without "--disable-vista-sdk-requirements". But I can build TSF support enabled build. Therefore, if we disable the TSF support by the option, and we cannot enable only TSF support with another option, I cannot develop on XP expecting to upgrade the VS version.
Flags: blocking1.9.1?
Is this a regression? Did we add TSF support recently?

Either way, this doesn't block final release. As Ted mentions, we already require the Vista SDK, it's available for free as part of the free toolchain, etc (see https://developer.mozilla.org/en/Windows_Build_Prerequisites)
Flags: blocking1.9.1? → blocking1.9.1-
I'd like the 1.9.1 branch to continue to be buildable without the Vista SDK, but I think we could take that patch even after the release of 3.1, since it would be very low-impact, not changing the actual code that's built in the official builds.
TSF isn't in the 1.9.1 branch so this is not a problem there.
Bug 509179 duplicate, eventually? (Or what is the current status?)
VS2005 isn't supported anymore.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.