Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 18574
9 years ago
9 years ago

People

(Reporter: Artem Karimov, Unassigned)

Tracking

3.0 Branch
x86_64
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; ru; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6 WebMoney Advisor
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; ru; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6

Are there any plans to include MNG support? FF3 doesn't support MNG now.

Reproducible: Always
(Reporter)

Updated

9 years ago
Version: unspecified → 3.0 Branch

Comment 1

9 years ago
(In reply to comment #0)
> Are there any plans to include MNG support?

No, get further information from bug 18574 please.

Oh, just to mention it: Firefox 3 and Opera support the backward-compatible APNG format, see https://wiki.mozilla.org/APNG_Specification
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 18574

Comment 2

9 years ago
But why the JNP has not been?

Comment 3

9 years ago
Oups : JNG (JPEG Network Graphics)

Comment 4

9 years ago
Agreed on the JNG. Very sad.
APNG is pretty much useless.
Virtually everything it does can be done with a bit of javascript and CSS in a much more cross-browser format, and, yeah no JNG.

MNG covered an excellent niche area between things like flash/canvas/webgl and basic formats like jpeg/png.

And there is still no useful replacement for JNG.  I suppose I could implement one using <canvas>, a mask jpeg of the alpha channel and a jpeg of the RGB.

Comment 5

9 years ago
Besides Flash, there is no JPEG format with transparencies. Suddenly, I use Flash. Yet there is JNG or JP2, but neither is supported.

Comment 6

9 years ago
Hm. You can do translucent jpeg with Flash?
I was trying to think of doing it with <canvas> - If I compress both a masking greyscale JPEG and an RGB JPEG, seems results could be some odd artifact side effects. I'll have to give that a shot, see what happens.
Also I guess less efficient.

Comment 7

9 years ago
> Hm. You can do translucent jpeg with Flash?

Yes, the JPG compression on a PNG is permitted with Adobe Flash.
PNG : 75 KB vs. SWF : 15 KB

Comment 8

9 years ago
That's sad, and even more damning of the politics that got JNG/MNG killed.
Still, I think I'd prefer to use <canvas> - avoids shoving a plugin in the page, much more flexible.
Might even be possible to get it working w/ ex-canvas...
You need to log in before you can comment on or make changes to this bug.