Stretched aPNG border image or scrolling in box shadow inset causes OGG audio to stutter

RESOLVED DUPLICATE of bug 704450

Status

()

Core
Graphics
--
minor
RESOLVED DUPLICATE of bug 704450
9 years ago
7 years ago

People

(Reporter: Homo Novis, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
Build Identifier: As above

I have yet to test this in nightly branch 3.1b3pre or trunk 3.2a1pre
Tests of those versions on non-windows OS are welcome.


Reproducible: Always

Steps to Reproduce:
1. View the attached html file that will hopefully work with attached ogg and png file.
2. Press Alt Shift X (or equivalent combo for X as accesskey) to focus subtitles
3. Press S to toggle the background animated spiral while audio is playing (any other key will pause/unpause the audio)
Actual Results:  
Audio stutters, and greatly slows down, then when the aPNG image is gone it skips ahead to where it would have been if it hadn't stuttered/slowed down.

Expected Results:  
Audio plays normally.
Seems that you forgot to upload the attachment.
(Reporter)

Comment 2

9 years ago
Created attachment 362953 [details]
ogg audio part 1
(Reporter)

Comment 3

9 years ago
Created attachment 362954 [details]
ogg audio part 2
(Reporter)

Comment 4

9 years ago
Created attachment 362956 [details]
Spiral aPNG
(Reporter)

Comment 5

9 years ago
Created attachment 362960 [details]
Testcase

Comment 6

9 years ago
The attachments on this bug are used to troll internet forums such as Slashdot. See this Slashdot post for example:
http://science.slashdot.org/comments.pl?sid=1134635&cid=26926859

Please close the bug and delete the attachments. Thanks.
(Reporter)

Updated

9 years ago
Summary: Stretched aPNG border image causes OGG audio to stutter → Stretched aPNG border image or box shadow inset causes OGG audio to stutter
(Reporter)

Comment 7

9 years ago
Created attachment 386030 [details]
box shadow inset testcase

To see box shadow inset causing stutter resize the browser so it's wider than it is tall (landscape) and hover the mouse over anything. If you have javascript turned off the audio will automatically start, otherwise click on step 3. Resizing the browser to be thinner than it is tall will remove the box shadow inset and audio won't stutter when mousing over things.
(Reporter)

Updated

9 years ago
Summary: Stretched aPNG border image or box shadow inset causes OGG audio to stutter → Stretched aPNG border image or scrolling in box shadow inset causes OGG audio to stutter
(Reporter)

Updated

9 years ago
Component: General → GFX: Thebes
Depends on: 509052
Product: Firefox → Core
Version: unspecified → Trunk
(Reporter)

Updated

9 years ago
Blocks: 476397
(Reporter)

Updated

9 years ago
Depends on: 499554
QA Contact: general → thebes
(Reporter)

Updated

9 years ago
Depends on: 484814
Can you please retest this with a trunk nightly?  It should behave much better now.
Please re-open this bug if the issue persists. Matthew Gregan mentions in comment 8 that it should be much better now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE

Comment 10

7 years ago
Duping as per bug 704450 comment 18
Resolution: INCOMPLETE → DUPLICATE
Duplicate of bug: 704450
You need to log in before you can comment on or make changes to this bug.