Find toolbar is too persistent

RESOLVED DUPLICATE of bug 537013

Status

()

Firefox
Toolbars and Customization
--
minor
RESOLVED DUPLICATE of bug 537013
9 years ago
8 years ago

People

(Reporter: David Reitter, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.6) Gecko/2009011912 Firefox/3.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.6) Gecko/2009011912 Firefox/3.0.6

Once opened with Command-F, the Find toolbar is too persistent and does not disappear when it is no longer needed.

Reproducible: Always



Expected Results:  
I would expect that the toolbar disappears as soon as another website is viewed, i.e. whenever the URL in the location field changes.  This includes switching somewhere else with a tab.

It is debatable whether Find should retain its state per tab, i.e. the toolbar should re-appear when switching back to the original tab.

Note that removing the find toolbar is inconvenient: just pressing Esc often does not do the job, as the toolbar loses focus sooner or later.  Command-F, Esc are needed.

This behavior has proved to be VERY inconvenient.

Updated

8 years ago
Severity: normal → minor
OS: Mac OS X → All
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 537013
You need to log in before you can comment on or make changes to this bug.