Closed Bug 479148 Opened 14 years ago Closed 7 years ago

hang on shutdown (APPLICATION_HANG_BusyHang_cfffffff_xul.dll!WrappedNativeJSGCThingTracer)

Categories

(Core :: JavaScript Engine, defect)

1.9.0 Branch
x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: aryx, Unassigned)

Details

(Keywords: hang)

Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.7pre) Gecko/2009021506 GranParadiso/3.0.7pre

The more CPU time Firefox has consumed during the session, the longer the shutdown lasts (can be longer than 10 minutes). I tried disabling add-ons to track it down, but with no real success (see http://forums.mozillazine.org/viewtopic.php?f=23&t=1044475 ).

*******************************************************************************
*                                                                             *
*                        Exception Analysis                                   *
*                                                                             *
*******************************************************************************

*** ERROR: Symbol file could not be found.  Defaulted to export symbols for F:\Software\Textprogramme\Adobe Reader\Reader\AcroRd32.dll - 
*************************************************************************
***                                                                   ***
***                                                                   ***
***    Your debugger is not using the correct symbols                 ***
***                                                                   ***
***    In order for this command to work properly, your symbol path   ***
***    must point to .pdb files that have full type information.      ***
***                                                                   ***
***    Certain .pdb files (such as the public OS symbols) do not      ***
***    contain the required information.  Contact the group that      ***
***    provided you with these symbols if you need this command to    ***
***    work.                                                          ***
***                                                                   ***
***    Type referenced: kernel32!pNlsUserInfo                         ***
***                                                                   ***
*************************************************************************
*************************************************************************
***                                                                   ***
***                                                                   ***
***    Your debugger is not using the correct symbols                 ***
***                                                                   ***
***    In order for this command to work properly, your symbol path   ***
***    must point to .pdb files that have full type information.      ***
***                                                                   ***
***    Certain .pdb files (such as the public OS symbols) do not      ***
***    contain the required information.  Contact the group that      ***
***    provided you with these symbols if you need this command to    ***
***    work.                                                          ***
***                                                                   ***
***    Type referenced: kernel32!pNlsUserInfo                         ***
***                                                                   ***
*************************************************************************

FAULTING_IP: 
ntdll!DbgBreakPoint+0
7c91120e cc              int     3

EXCEPTION_RECORD:  ffffffff -- (.exr 0xffffffffffffffff)
ExceptionAddress: 7c91120e (ntdll!DbgBreakPoint)
   ExceptionCode: 80000003 (Break instruction exception)
  ExceptionFlags: 00000000
NumberParameters: 3
   Parameter[0]: 00000000
   Parameter[1]: 00000002
   Parameter[2]: 00000003

FAULTING_THREAD:  00000000

BUGCHECK_STR:  HANG

PROCESS_NAME:  firefox.exe

ERROR_CODE: (NTSTATUS) 0xcfffffff - <Unable to get error code text>

NTGLOBALFLAG:  400

APPLICATION_VERIFIER_FLAGS:  0

DERIVED_WAIT_CHAIN:  

Dl Eid Cid     WaitType
-- --- ------- --------------------------
   0   ea8.d50 Unknown                

WAIT_CHAIN_COMMAND:  ~0s;k;;

BLOCKING_THREAD:  00000d50

DEFAULT_BUCKET_ID:  APPLICATION_HANG_BusyHang

PRIMARY_PROBLEM_CLASS:  APPLICATION_HANG_BusyHang

LAST_CONTROL_TRANSFER:  from 6010f4bc to 606588db

STACK_TEXT:  
0012b8e4 6010f4bc 016f1c20 0a599564 00000030 xul!WrappedNativeJSGCThingTracer+0xb [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\js\src\xpconnect\src\xpcwrappednativescope.cpp @ 358]
0012b914 605beb8e 016f1c20 606588d0 0012b9ac js3250!JS_DHashTableEnumerate+0x6c [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\js\src\jsdhash.c @ 716]
0012b938 6056126f 003c7070 04c22b50 00000000 xul!XPCJSRuntime::TraceXPConnectRoots+0xae [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\js\src\xpconnect\src\xpcjsruntime.cpp @ 379]
0012b950 6010a625 04c22b50 00000002 04c22b50 xul!XPCCycleCollectGCCallback+0x6f [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\js\src\xpconnect\src\nsxpconnect.cpp @ 446]
0012ba10 6013d210 04c22b50 00000000 04c22b50 js3250!js_GC+0x2b5 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\js\src\jsgc.c @ 3247]
0012ba34 60103d5c 00000002 00006730 605a1b86 js3250!js_DestroyContext+0xc0 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\js\src\jscntxt.c @ 437]
0012ba40 605a1b86 04c22b50 082b5b00 6049898b js3250!JS_DestroyContext+0xc [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\js\src\jsapi.c @ 1035]
0012ba4c 6049898b 00394380 04c22b50 00000000 xul!nsXPConnect::ReleaseJSContext+0x3b [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\js\src\xpconnect\src\nsxpconnect.cpp @ 2084]
0012ba60 6049890e 0ab483c4 604f58b6 60d58e3c xul!nsJSContext::Unlink+0x73 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\dom\src\base\nsjsenvironment.cpp @ 1241]
0012ba68 604f58b6 60d58e3c 082b5b00 00371000 xul!nsJSContext::cycleCollection::Unlink+0x14 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\dom\src\base\nsjsenvironment.cpp @ 1249]
0012baa4 60610337 04dc9704 00000001 0030d800 xul!nsCycleCollector::CollectWhite+0x86 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\xpcom\base\nscyclecollector.cpp @ 1660]
0012bab4 60561309 003a32b0 00000000 0012bb88 xul!nsCycleCollector::FinishCollection+0x8 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\xpcom\base\nscyclecollector.cpp @ 2434]
0012bac8 6010ac61 003a32b0 00000001 003a32b0 xul!XPCCycleCollectGCCallback+0x109 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\js\src\xpconnect\src\nsxpconnect.cpp @ 453]
0012bb88 60101d60 003a32b0 00000000 00394390 js3250!js_GC+0x8f1 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\js\src\jsgc.c @ 3534]
0012bb9c 60612034 003a32b0 003a32b0 60561200 js3250!JS_GC+0x30 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\js\src\jsapi.c @ 2469]
0012bc60 605fe049 60c9bf34 0249f760 00000000 xul!nsXPConnect::Collect+0x7b [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\js\src\xpconnect\src\nsxpconnect.cpp @ 530]
0012fb14 6064cd0e 00000001 6064cced 6075e476 xul!nsCycleCollector::Collect+0x8a [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\xpcom\base\nscyclecollector.cpp @ 2277]
0012fb1c 6064cced 6075e476 00000000 00000008 xul!nsCycleCollector_collect+0x11 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\xpcom\base\nscyclecollector.cpp @ 2899]
0012fb20 6075e476 00000000 00000008 60c9bf34 xul!nsJSContext::CC+0x2d [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\dom\src\base\nsjsenvironment.cpp @ 3346]
0012fb34 6053eed7 0249f760 00000000 60c9bf34 xul!nsUserActivityObserver::Observe+0x1539c6
0012fb58 605de422 0031aa40 00000000 60c9bf34 xul!nsObserverService::NotifyObservers+0x137 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\xpcom\ds\nsobserverservice.cpp @ 181]
00000000 00000000 00000000 00000000 00000000 xul!nsUITimerCallback::Notify+0x73 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\content\events\src\nseventstatemanager.cpp @ 212]


FOLLOWUP_IP: 
xul!WrappedNativeJSGCThingTracer+b [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\js\src\xpconnect\src\xpcwrappednativescope.cpp @ 358]
606588db 7703            ja      xul!WrappedNativeJSGCThingTracer+0x10 (606588e0)

SYMBOL_STACK_INDEX:  0

SYMBOL_NAME:  xul!WrappedNativeJSGCThingTracer+b

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: xul

IMAGE_NAME:  xul.dll

DEBUG_FLR_IMAGE_TIMESTAMP:  4998331a

STACK_COMMAND:  ~0s ; kb

BUCKET_ID:  HANG_xul!WrappedNativeJSGCThingTracer+b

FAILURE_BUCKET_ID:  APPLICATION_HANG_BusyHang_cfffffff_xul.dll!WrappedNativeJSGCThingTracer

Followup: MachineOwner
---------
Keywords: hang
archaeopteryx, still see this with v3.6?
Severity: major → critical
I still see shutdown hangs, last week I had 49 minutes shutdown time.
Does this still reproduce?
Firefox 15.0 on Windows XP SP3 32 bit

Shutdown after 2h and 35min cpu usage: Shutdown in 145 seconds, but cpu usage was no issue on shutdown (some peaks, but always below 80%). I guess it was slow because memory pagination was involved.
Assignee: general → nobody
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.