Mac-Can't submit any secure form

VERIFIED FIXED

Status

()

Core
HTML: Form Submission
P2
critical
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: Mike Pinkerton (not reading bugmail), Assigned: Patrick C. Beard)

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-][dogfood+][nsbeta3+] SSL WORKS!)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
- Go to www.amazon.com and click "your account" button
- select "view items ordered in last year" and click "Go" button
- enter username and password, go through crappy security dialogs
- click "go back to account maintenance page"
- once there, try to do the same thing again (select view items ordered in last N 
months, and click "Go" image)

expected:
- url loads

actual:
- nothing happens. Form does not ever submit. Click is ignored. Other clicks on 
_links_ work, but not on images that submit the form.
(Reporter)

Comment 1

18 years ago
i can't order anything from amazon.com, i think that's dogfood for commercial, 
don't you think?

Another way to duplicate the problem is to try to purchase a DVD. Once you get to 
the page where you have to select your address, the only way to continue is to 
click an image to submit the form.
Keywords: dogfood, nsbeta2, nsbeta3
(Reporter)

Comment 2

18 years ago
just tried www.vanguard.com and i can't actually log into my account. Seems that 
clicking the "Continue" button on the logon screen does nothing as well. It's not 
an image, just a normal button.

Maybe all form submission is broken with https, not just with image submit 
buttons.
(Reporter)

Comment 3

18 years ago
i tried to sign in to bofA and it doesn't work either. same problem as amazon.
(Reporter)

Comment 4

18 years ago
trying to log into 401k.com, i can submit my username/password, but I can't get 
past the screen where it asks for my mother's maiden name (again, no image 
submit, just a normal submit).

changing topic. this is very very serious.
Summary: Can't submit any secure form where submit button is an image → Can't submit any secure form

Comment 5

18 years ago
Putting on [nsbeta2+][dogfood+] radar.
Whiteboard: [nsbeta2+][dogfood+]

Comment 6

18 years ago
Assigning to beard and ccing ddrinan for ideas of what is happening here.

junruh, have you been seing this?
Assignee: rods → beard
(Assignee)

Comment 7

18 years ago
This is a regression. I was able to purchase a book from amazon and logon to
e-trade in the past.

Comment 8

18 years ago
*** Bug 47349 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
cc'ing more people.
Priority: P3 → P2

Comment 10

18 years ago
This works fine for me in PR2.  Is this bug report for PR2-m17 or m18?

Updated

18 years ago
Summary: Can't submit any secure form → Mac-Can't submit any secure form

Comment 11

18 years ago
Release noted. "When in secure mode (https), you may not be able to submit a 
form on the Mac, and thus may not be able to login to secure sites." 
Keywords: relnote

Comment 12

18 years ago
In doing some digging, I've found that this exists in the 2000-07-30-04-M17 
build (the earliest M17 build currently available on sweetlou).  I also tried 
2000-06-14-11-M16, and am blocked by a bug that was fixed sometime in M17.  I'll 
check with leaf and granrose to see if I can obtain some other July M17 builds 
to try to narrow the possible origin.
(Reporter)

Comment 13

18 years ago
Great.

This should go nicely with the other "this product sucks donkey" comments from 
the general macintosh community. I just love my job.

Comment 14

18 years ago
Per PST PR2 open bugs review, marking this [nsbeta2-].  But is definitely a
[nsbeta3+] bug.  beard, hope you don't ming, I added [nsbeta3+].  This is hot to
fix ASAP please.
Keywords: relnote → relnote2
Whiteboard: [nsbeta2+][dogfood+] → [nsbeta2-][dogfood+][nsbeta3+]
(Assignee)

Comment 15

18 years ago
This appears to be a problem with the certificate database, not with SSL itself. 
If I copy my security database files "Security Modules", Certificates7 and "Key 
Database3" from my Mac 4.74 profile, I can log into www.optionslink.com. This 
narrows down the problem.
Whiteboard: [nsbeta2-][dogfood+][nsbeta3+] → [nsbeta2-][dogfood+][nsbeta3+] SSL WORKS!
(Assignee)

Comment 16

18 years ago
Another data point, using aka.mcom.com, with my 4.74 certificates, it asks me to 
authenticate with my certificate, and then fails to load the page. If I then hit 
reload, the page loads correctly. So, there's some interaction between the HTTP 
proxy server security dialogs, and SSL page loading.
(Assignee)

Comment 17

18 years ago
The debug build on my machine works. I've even built the optmized version of the 
PSM shared library, and that works as well. If I use the built version from 8/11, 
that doesn't work, so I'm baffled.
Status: NEW → ASSIGNED

Comment 18

18 years ago
Just to be clear... SSL has been working for a while... but the form submission
part is where the bustage sits.

Patrick: Are you saying that form submission works on SSL now in your build?

Junruh: Can you test on current build?
QA Contact: ckritzer → junruh
(Assignee)

Comment 19

18 years ago
I can't reproduce the problem with a build on my own machine, neither with the 
debugging build nor the optimized build. It all works. I've been able to look at 
my amazon account just fine. This is starting to smell like a configuration 
problem with the installed bits.
(Reporter)

Comment 20

18 years ago
to summarize what beard is saying (so someone doesn't come along and mark this 
WFM), a build from source (debug or opt) works fine, but the packaged bits fail 
for beard on his machine as they do on mine.

Comment 21

18 years ago
I can still reproduce it. Go to 
https://trading.etrade.com/cgi-bin/gx.cgi/AppLogic+Loginpage
Enter some info in the username and password fields, and click on the logon 
button. Nothing happens. Mac only.
(Assignee)

Comment 22

18 years ago
OK, with my current build, I CAN log into www.amazon.com, but I can't log in to 
www.optionslink.com. Making progress.
(Assignee)

Comment 23

18 years ago
Created attachment 12960 [details] [diff] [review]
Patch to fix unitialized variable.
(Assignee)

Comment 24

18 years ago
With this patch, a rebuilt PSMGlue.shlb dropped into last Friday's build is able 
to submit secure forms.

Comment 25

18 years ago
Fixed. The patch works with the 081504 build. Will verify in the next build 
after beard checks the new file in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 26

18 years ago
Fix is checked in.

Comment 27

18 years ago
Verified.
Status: RESOLVED → VERIFIED

Comment 28

18 years ago
Verified on Mac M17 respin with a new PSMGlue.shlb file. This file should now be 
included in the 8-17-21 Mac builds.

Updated

14 years ago
OS: Mac System 9.x
You need to log in before you can comment on or make changes to this bug.