ecma_2/Statements/forin-002.js FAIL browser only

VERIFIED FIXED

Status

()

Core
JavaScript Engine
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: bc, Assigned: mrbkap)

Tracking

(4 keywords)

1.9.1 Branch
fixed1.9.0.12, regression, testcase, verified1.9.1
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9.0.12 +
wanted1.9.0.x +
in-testsuite +
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sg:nse] regression from security fix 460882, URL)

(Reporter)

Description

10 years ago
<http://test.bclary.com/tests/mozilla.org/js/js-test-driver-standards.html?test=ecma_2%2FStatements%2Fforin-002.js;language=type;text/javascript>

([object Window @ 0x1c510ec0 (native @ 0x1c510270)])[globalStorage] == eval ( globalStorage ) reason: wrong value

regressed on mozilla-1.9.1 only as far as I can see. Regressed by bug 460882 comment 31.

See also bug 478910 but I did not see this particular error on 1.9.1 tracemonkey or 1.9.2 so I'm filing this as a separate bug.
Flags: in-testsuite+
Flags: in-litmus-
(Reporter)

Updated

10 years ago
Whiteboard: [sg:nse] regression from security fix
(Assignee)

Comment 1

10 years ago
Bob, is this not the same as bug 453649?
(Reporter)

Comment 2

10 years ago
It does look like it. Not sure why I didn't show it failing before on mozilla-1.9.1 or why bisection pointed to bug 460882.
(Assignee)

Comment 3

10 years ago
This might be a new symptom of the same bug that bug 460882 exposed.
Flags: wanted1.9.0.x+
(Reporter)

Comment 4

9 years ago
fixed by bug 453649
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/dced1fb507d7
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Depends on: 453649
Keywords: fixed1.9.1
Resolution: --- → FIXED
(Reporter)

Comment 5

9 years ago
v 1.9.1, 1.9.2
Status: RESOLVED → VERIFIED
Keywords: fixed1.9.1 → verified1.9.1
Whiteboard: [sg:nse] regression from security fix → [sg:nse] regression from security fix 460882
Flags: blocking1.9.0.12?
Flags: blocking1.9.0.12? → blocking1.9.0.12+
Assignee: general → mrbkap
(Assignee)

Updated

9 years ago
Keywords: fixed1.9.0.12
Group: core-security
You need to log in before you can comment on or make changes to this bug.