Cut/copy/paste keyboard shortcuts not working in "Save to PDF" print dialog in Firefox Mac

RESOLVED DUPLICATE of bug 433778

Status

()

RESOLVED DUPLICATE of bug 433778
10 years ago
10 years ago

People

(Reporter: gordeon, Unassigned)

Tracking

3.5 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_6; en-us) AppleWebKit/525.27.1 (KHTML, like Gecko) Version/3.2.1 Safari/525.27.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2

When using the "Save to PDF" option when printing in Firefox 2.x and 3.x on Mac OS X, cut/copy/paste keyboard shortcuts do not work in any of the text fields.  (Cmd+X, Cmd+C, Cmd+V).  The only way to get this functionality is to use the contextual menu.

Reproducible: Always

Steps to Reproduce:
1.) Print a webpage
2.) Click the "PDF" button
3.) Select "Save as PDF..." in the menu

You will find that you cannot cut/copy/paste in any of the text fields. Those text fields are labeled as followed:

"Save As:"
"Title:"
"Subject:"
"Keywords:"
Actual Results:  
You will find that you cannot cut/copy/paste in any of the text fields. Those text fields are labeled as followed:

"Save As:"
"Title:"
"Subject:"
"Keywords:"

Expected Results:  
Should be able top use Cmd+X, Cmd+C, Cmd+V
(Reporter)

Updated

10 years ago
Version: unspecified → 3.1 Branch
(Reporter)

Comment 1

10 years ago
This functionality works in Safari (3.2.1), so it is a Firefox-specific issue.
(Reporter)

Comment 2

10 years ago
Created attachment 363238 [details]
"Save to PDF" print dialog - cut-copy-paste keyboard shortcuts not working
Not a shell integration bug... this is either File Handling or possibly one of the Core -> Printing components
Component: Shell Integration → File Handling
QA Contact: shell.integration → file.handling
Confirmed, I see this using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090223 Firefox but I think it might be a dupe. I will search now.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I found the duplicate bug so resolving this...
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 433778
You need to log in before you can comment on or make changes to this bug.