If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

HTML elements should always be in XHTML namespace per HTML5

RESOLVED DUPLICATE of bug 468708

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 468708
9 years ago
9 years ago

People

(Reporter: Alexey Proskuryakov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_6; ru-ru) AppleWebKit/525.27.1 (KHTML, like Gecko) Version/3.2.1 Safari/525.27.1
Build Identifier: 

Per HTML5, HTML elements should always have a "http://www.w3.org/1999/xhtml" namespace, even in non-XML documents. WebKit implements this, and that hasn't caused any compatibility problems, as far as I know.

---------------
To ease migration from HTML to XHTML, UAs conforming to this specification will place elements in HTML in the http://www.w3.org/1999/xhtml namespace, at least for the purposes of the DOM and CSS. The term "elements in the HTML namespace", or "HTML elements" for short, when used in this specification, thus refers to both HTML and XHTML elements.

Unless otherwise stated, all elements defined or mentioned in this specification are in the http://www.w3.org/1999/xhtml namespace, and all attributes defined or mentioned in this specification have no namespace (they are in the per-element partition).
---------------



Reproducible: Always

Steps to Reproduce:
<script>alert(document.getElementsByTagName("script")[0].namespaceURI)</script>

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 468708
You need to log in before you can comment on or make changes to this bug.