SVG Viewer BIDI Locale Support

RESOLVED DUPLICATE of bug 311545

Status

()

--
major
RESOLVED DUPLICATE of bug 311545
10 years ago
10 years ago

People

(Reporter: alantangyl, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2

The built-in SVG Viewer does not have BIDI locale support. The characters in Arabic language are all reversed and the whole string does not append from right to left.

Reproducible: Always

Steps to Reproduce:
1. View a SVG image with Arabic or Hebrew language



Why does Firefox just use SVG viewer from Adobe? I cannot even override the built-in viewer by putting the SVG viewer plugin into Firefox plugin folder.
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 311545
You need to log in before you can comment on or make changes to this bug.