onmouseover prevents CSS a:hover (etc) definitions

VERIFIED DUPLICATE of bug 38380

Status

()

Core
CSS Parsing and Computation
P3
normal
VERIFIED DUPLICATE of bug 38380
17 years ago
17 years ago

People

(Reporter: Roland Unger, Assigned: Pierre Saslawsky)

Tracking

({verifyme})

Trunk
x86
Windows 98
verifyme
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (Win98; I)
BuildID:    2000080712

Normally a:hover definitions for the <a> tag work. But if you add
onmouseover and onmouseout statements in the <a>-tag for instance
to give further informations in the status bar then the CSS
definitions are ignored. (Bug found both in M16 and M17).

Reproducible: Always
Steps to Reproduce:
1.Define CSS definitions like a:active, a:hover { color: brown }
2.Test it: <a href="test.htm">Link</a>
3.Add an onmousover statement like <a href="test.htm"
onmouseover="return ShowStatus('Text')">Link</a>

function ShowStatus(msg) {
   window.status=msg;
   return true;
}


Actual Results:  The bug occurs after adding the JavaScript statement: no change
of CSS colors (the script works).						
	

Expected Results:  Change of <a>-tag properties as defined in CSS.
(Reporter)

Comment 1

17 years ago
For the page mentioned above: Move your mouse over "Home".
Known bug.

*** This bug has been marked as a duplicate of 38380 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Adding keyword 'verifyme' to bug.
Keywords: verifyme

Comment 4

17 years ago
Verified dup of #38380
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.