Adding a vcard from an email does not work.

RESOLVED FIXED in Thunderbird 3.0b3

Status

MailNews Core
Address Book
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Usul, Assigned: standard8)

Tracking

({regression})

Trunk
Thunderbird 3.0b3
regression
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [has patch])

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
Created attachment 363894 [details]
Example of such email

The card is attached and also displyed inline the email. If I click on the nice + sign to add the vcard to my address book, a sheet containing the data from the card is presented to me. I can either OK or Cancel. If I OK the button stays blue and nothing else happens. I can then click cancel to have the sheet go away.

The console log contains the following :
Error: uncaught exception: [Exception... "Cannot modify properties of a WrappedNative"  nsresult: "0x80570034 (NS_ERROR_XPC_CANT_MODIFY_PROP_ON_WN)"  location: "JS frame :: chrome://messenger/content/addressbook/abCardOverlay.js :: NewCardOKButton :: line 369"  data: no]


Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090223 Thunderbird/3.0b2 is the version I tested with.
Taking, will fix for b3 - I can see what its trying to do, I've got to work out if there is a valid way or not. It has certainly been an issue for quite a while, but we should fix it for final at least.
Assignee: nobody → bugzilla
Flags: blocking-thunderbird3+
OS: Mac OS X → All
Hardware: x86 → All
Target Milestone: --- → Thunderbird 3.0b3
Created attachment 364163 [details] [diff] [review]
The fix

Turned out easier than I thought - the reason we can't modify properties is that allowRemoteContent isn't always in the window arguments. We need to verify that it is before trying to set it to return to the caller.

Not sure this is the 100% ideal way of returning that flag, but bug 457296 would remove the need.

Also note for testing that we have bug 461660 which means allow remote image checkbox isn't shown correctly across restarts of the app (also a blocker).
Attachment #364163 - Flags: superreview?(neil)
Attachment #364163 - Flags: review?(bienvenu)
Whiteboard: [has patch][needs review neil,bienvenu]

Comment 3

10 years ago
Comment on attachment 364163 [details] [diff] [review]
The fix

Ah yes, this is because we're getting an nsIAbCard in this case, which has no such idl property.
Attachment #364163 - Flags: superreview?(neil) → superreview+
Component: Address Book → Address Book
Product: Thunderbird → MailNews Core
QA Contact: address-book → address-book

Updated

10 years ago
Attachment #364163 - Flags: review?(bienvenu) → review+
Checked in: http://hg.mozilla.org/comm-central/rev/42f15182c525
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: [has patch][needs review neil,bienvenu] → [has patch]
You need to log in before you can comment on or make changes to this bug.