Context menu for audio files should not have a "View Video" option

RESOLVED DUPLICATE of bug 557278

Status

()

Toolkit
Video/Audio Controls
RESOLVED DUPLICATE of bug 557278
9 years ago
7 years ago

People

(Reporter: tchung, Assigned: mano)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090224 Shiretoko/3.1b3pre Ubiquity/0.1.5
Build Identifier: 

when playing a audio file over the browser, (eg. .wav files), the right click context menu should not display the text to "View Video".   As its obviously not a video, perhaps we can gray out this option for all audio files.

Reproducible: Always

Steps to Reproduce:
1. On trunk or 1.9.1 branch nightly
2. go to the URL, and choose any of the wav samples
3. move cursor to upper left hand corner, and right-click the area > "View Video"
4. Verify this text doesnt make sense for a audio file, and should be disabled or reworded for file types.

Actual Results:  
"View video" menu item for a audio file

Expected Results:  
"Play audio" text instead or gray out the "View video" label for audio files.
(Reporter)

Updated

9 years ago
Version: unspecified → Trunk
(Reporter)

Updated

9 years ago
Depends on: 449149
There's code to suppress this item when used with an <audio> element, but loading a media file directly actually results in a <video> (via nsVideoDocument.cpp).

It might be interesting to have something like a nsAudioDocument for media that's expected to be audio-only, although we'll still have the problem of "foo.ogg" maybe being video, maybe being audio.

So, we should suppress this menu item in the same style as bug 462368.
Assignee: nobody → mano
Status: NEW → ASSIGNED
Component: Video/Audio → Video/Audio Controls
Product: Core → Toolkit
QA Contact: video.audio → video.audio
Version: Trunk → unspecified

Updated

7 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 557278
You need to log in before you can comment on or make changes to this bug.