Context menu shows everything / every option at once

VERIFIED DUPLICATE of bug 425575

Status

()

VERIFIED DUPLICATE of bug 425575
10 years ago
10 years ago

People

(Reporter: dln385, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6 (.NET CLR 3.5.30729)

When I do a right-click-and-drag, a very long context menu with 46 items in it appears. This happens when I press the right-mouse button in the middle of a maximized firefox window, drag the cursor to the top of the screen, and release. It has happened for me three times.

Reproducible: Sometimes

Steps to Reproduce:
1. Maximize Firefox
2. Depress the right mouse button on a web page
3. Drag the cursor up to the top of the screen
4. Release the right mouse button
Actual Results:  
A context menu with 46 items in it appears.

Expected Results:  
A small context menu with context-specific items should appear.

The first time this happened, I was reading my email on Gmail.com. I could not reproduce it directly afterward. The next time, the page <http://java.com/en/download/help/index.xml> was in the middle of loading when it happened. I proceeded to reproduce it a second time while the page was still loading. I have screen shots of all three events. The context menu is exactly the same every time.
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch
(Reporter)

Comment 1

10 years ago
Created attachment 364122 [details]
A picture of the long context menu
(Reporter)

Comment 2

10 years ago
Created attachment 364124 [details]
A full screen shot including the long context menu
(Reporter)

Comment 4

10 years ago
I am using the default theme. All of my extensions and plugins are up-to-date. I will try to reproduce the bug in safe mode.
(Reporter)

Comment 5

10 years ago
I have now replicated the bug several times in safe mode. It is not caused by an extension or theme. I have not yet found a procedure that consistently replicates the bug.
(Reporter)

Comment 6

10 years ago
I spoke too soon: I found what causes the bug. The following procedure will work consistently:
1. Navigate to a web page in a Firefox window (does not need to be maximized).
2. Right-click on the page (eg. a link or image or blank space) to get a unique context menu.
3. Close that context menu. (Left click on the page or press Esc.)
4. Depress the right mouse button on the page
5. Drag the cursor anywhere off the page. (Off the Firefox window works too)
6. Release the right mouse button

You will now see the same context menu you saw in step 2. To get the long context menu, open a new Firefox window or tab that you have not right-clicked in yet, and proceed with step 4.

Comment 7

10 years ago
Had a bit of trouble following your STR. Here's a simpler method:

Steps to reproduce:
1. ctrl+n to open a new window
2. right-click, hold, and drag to outside of windows
3. release and get long unabridged context menu

Confirmed on WinXP with 3.0.6 and 3.1b3pre. Could not reproduce on Linux. (context menu comes up on mousedown instead of mouseup) Might be a dupe, though.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: dupeme?

Comment 8

10 years ago
Yep, already filed. Found it.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme?
Duplicate of bug: 431664
Status: RESOLVED → VERIFIED
Duplicate of bug: 425575
You need to log in before you can comment on or make changes to this bug.