Closed Bug 480195 Opened 13 years ago Closed 13 years ago

http referrer information is not being passed when using flowplayer

Categories

(Firefox :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 410904

People

(Reporter: cyberfred2002, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.6) Gecko/2009011912 Firefox/3.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.6) Gecko/2009011912 Firefox/3.0.6

I am hosting .flv files on a apache webserver and playing them with an open source flash video player called flowplayer.  To restrict access to the site I am using http referrer rules to restrict my users from only seeing the videos from a particular site.  When my users use IE6/7, Chrome, and Safari they have no problems accessing the content.  If they use FF3 on any platform they get denied.  I started looking through the logs and this is what I found:

Firefox:

1235520520 11573 212.2.4.2 48177179 72.21.84.101 80 TCP_HIT/200 48177505 GEThttp://somecdn.com/roadshow_part_1.flv - 0 440 "-" "Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.6) Gecko/2009011912 Firefox/3.0.6" 996 "-"

IE7:

1235569306 31462 212.2.4.2 48140750 72.21.87.101 80 TCP_MISS/200 48141076 GEThttp://somecdn.com/roadshow_part_1.flv - 31590 48141636 http://somelocation.com/flowplayer/flowplayer-3.0.5.swf" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022; MS-RTC LM 8; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)" 996 "-"


I have used refcontrol to try to force the correct http referrer but I still haven't been able to get this to work.  I also verified in my about:config settings that network.http.sendreferrerheader is set to 2.

Reproducible: Always

Steps to Reproduce:
1. Get a .flv video and put it up on apache.
2. Have a second server and download flowplayer 3.0.5 and copy over to that second server.
3. Use the following code snippet to help setup the html page using flowplayer:

<a   
    href="http://www.example.com/somevideo.flv
    style="display:block;width:425px;height:300px;"   
    id="player">  
</a>  
  
<!-- this script block will install Flowplayer inside previous anchor tag -->  
<script language="JavaScript">  
    flowplayer("player", "../flowplayer/flowplayer-3.0.5.swf");
</script>  

4. access the page, then look at the apache logs on the server hosting the .flv logs.
Actual Results:  
The log file does not show a referrer domain.

Expected Results:  
The log file show have shown a referrer domain.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 337766
Duplicate of bug: 410904
You need to log in before you can comment on or make changes to this bug.