Creating a second tab does not pan down urlbar.

VERIFIED FIXED

Status

VERIFIED FIXED
10 years ago
8 years ago

People

(Reporter: tonikitoo, Unassigned)

Tracking

Trunk
ARM
Maemo

Details

(Reporter)

Description

10 years ago
whenever user creates a new tab by tapping the "+" button on the left sidebar, urlbar should get visible and focused so user could just start typing the desired url.
hmm, this works for me on linux desktop
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> hmm, this works for me on linux desktop

mark: try this:

1) launch fennec
2) open a new tab through the + button (it will open about:blank)
3) repeat 2
(Reporter)

Comment 3

10 years ago
subject was: "After creating a new tab, focus should go to urlbar".

steps to reproduce in comment #2 .
Summary: After creating a new tab, focus should go to urlbar. → Creating a new tab does not get focus to the urlbar if current url is about:blank
Ah, focus _is_ in the URLBar, but the URLBar isn't panned down into view. If you pull the URLBar down, you'll see the cursor blinking in the field.

We need to figure out why panning down isn't working on the second "+". I bet the  | this.mode | is stuck and the | BrowserUI.show(...) | is bailing out right away.
(Reporter)

Comment 5

10 years ago
err .. title changed to describe the real problem

subject was: "Creating a new tab does not get focus to the urlbar if current url is about:blank"

sorry for spamming :(
Summary: Creating a new tab does not get focus to the urlbar if current url is about:blank → Creating a second tab does not pan down urlbar.
Seems to be fixed now
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 7

8 years ago
VERIFIED FIXED on:

Build ID: Mozilla/5.0 (Maemo; Linux armv7l; rv:6.0a1) Gecko/20110510
Firefox/6.0a1 Fennec/6.0a1

Device: Nokia N900 (Maemo GTK)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.