Closed Bug 480279 Opened 11 years ago Closed 11 years ago

Allow mochitests to launch under a debugger or valgrind

Categories

(Testing :: Mochitest, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9.2a1

People

(Reporter: bent.mozilla, Assigned: bent.mozilla)

References

Details

(Keywords: fixed1.9.1, Whiteboard: [fixed1.9.1b4])

Attachments

(1 file)

Simple changes to launch the mochitest harness under a debugger. Works great for valgrind, a little less great for gdb, but what do you guys think? This at least means I don't have to hack the harness when I want to run valgrind.
Attachment #364281 - Flags: review?(sayrer)
Assignee: nobody → bent.mozilla
Status: NEW → ASSIGNED
Duplicate of this bug: 477269
I filed bug 477269 not long ago, but you have a patch.
Looks good to me, but I'd probably have to play with it for awhile to be completely confident that the mode of interaction is optimal.
Attachment #364281 - Flags: review?(sayrer) → review?(jwalden+bmo)
Attachment #364281 - Flags: review?(jwalden+bmo) → review+
Summary: Allow mochitests to launch under a debugger → Allow mochitests to launch under a debugger valgrind
Summary: Allow mochitests to launch under a debugger valgrind → Allow mochitests to launch under a debugger or valgrind
Pushed changeset 356458e646d0 to mozilla-central.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.2a1
Version: unspecified → Trunk
Whiteboard: [needs 1.9.1 landing: after bug 460515]
Comment on attachment 364281 [details] [diff] [review]
Patch, v1
[Checkin: See comment 4 & 5]


http://hg.mozilla.org/releases/mozilla-1.9.1/rev/3ed22a6e3f37

After fixing context for:
{
patching file build/automation.py.in
Hunk #1 FAILED at 401
Hunk #3 FAILED at 446
2 out of 3 hunks FAILED
patching file testing/mochitest/runtests.py.in
Hunk #5 FAILED at 466
1 out of 5 hunks FAILED
}
Attachment #364281 - Attachment description: Patch, v1 → Patch, v1 [Checkin: See comment 4 & 5]
Flags: in-testsuite-
Keywords: fixed1.9.1
Whiteboard: [needs 1.9.1 landing: after bug 460515] → [fixed1.9.1b4]
I guess I don't mind that this was checked in on branch but I don't see anyone giving approval for it landing there...
It's a testing-only change, and those have never required approval.  Maybe this is a lenient interpretation of the policy, but "beg forgiveness" > "ask permission" in my book as long as you're sure the change won't break anything.  ;-)
Duplicate of this bug: 417520
Yes, I have been broadly interpreting the testing approval grant to include test harness changes. I have yet to hear a complaint from other drivers, so I conclude that nobody minds.
Using this to run gdb doesn't work for me on Mac.  See bug 485531.
You need to log in before you can comment on or make changes to this bug.