cannot attach files on gmail

VERIFIED FIXED in mozilla1.9.2a1

Status

()

Core
XPConnect
P2
major
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: armenzg, Unassigned)

Tracking

({regression, verified1.9.0.12, verified1.9.1})

Trunk
mozilla1.9.2a1
regression, verified1.9.0.12, verified1.9.1
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 479442], URL)

(Reporter)

Description

9 years ago
They have added a feature yesterday that shows a progress bar when you attach new files. It works for FF3.0.7 but not for the following builds:

- Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20090226 Minefield/3.1b3pre

- Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090226 Minefield/3.2a1pre

Reproduce steps:
1) Compose email
2) Select the option to attach a file
3) Select a file and accept
Results:
- There is no file attached
Flags: blocking-firefox3.1?
Component: General → General
Flags: blocking-firefox3.1?
Product: Firefox → Core
QA Contact: general → general
Version: 3.1 Branch → unspecified
Flags: blocking1.9.1?

Comment 1

9 years ago
Temp work around : set GMail option to use basic attachment feature
Settings > Attachments > Basic attachment features
Also this one seems to be caused by Bug 460882.
Keywords: regression
Version: unspecified → Trunk
Duplicate of this bug: 480530

Comment 4

9 years ago
Also happens with Win XP sp3
--> Core::XPConnect, and cc'ing the patch author and reviewer of bug 460882 which has been identified as the regression in comment 2.
Component: General → XPConnect
Flags: blocking1.9.1? → blocking1.9.1+
Priority: -- → P2
QA Contact: general → xpconnect

Comment 6

9 years ago
I found that the bug doesn't exist on "2009-02-17-00-comm-central" nightly build and it happens only after the "2009-02-18-00-comm-central" nightly build.  Maybe someone could check out what checkins has caused the trouble.

Comment 7

9 years ago
(In reply to comment #6)
>  Maybe someone could check out what checkins has caused the trouble.

That is already known - see comment 2
That stops people from being able to send files to friends, colleagues or others. Not everyone knows this workaround. Raising severity to at least major.
Severity: normal → major
OS: Windows Vista → All
Hardware: x86 → All
Priority: P2 → P1
Priority: P1 → P2
Duplicate of this bug: 481004

Updated

9 years ago
Duplicate of this bug: 481238
This should be fixed by the patch for bug 479442 (whose checkin message pointed here).
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Keywords: fixed1.9.1

Comment 12

9 years ago
I checked this with today's build, and Gmail attachments are now working.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090304 Shiretoko/3.1b3pre ID:20090304033811

This now works for me.

Comment 14

9 years ago
Still does not work for me. When I click to add an attachment nothing happens. Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090304 Minefield/3.2a1pre ID:20090304022538
sd: Which version of Gmail are you using? I tested both the classic and new version using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090304 Minefield/3.2a1pre and have no problems adding a single attachment or multiple attachments.  If you have extensions installed, please also try in safe mode so we can eliminate that as an issue.
I was able to verify the fix on OS X and Windows with both Shiretoko and Minefield. I highly suspect that for comment 14 an add-on blocks this function. Are they using flash now? It looks like.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090304 Minefield/3.2a1pre

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090304 Shiretoko/3.1b3pre ID:20090304022008

Marking verfied based on all the other WFM comments.
Status: RESOLVED → VERIFIED
Depends on: 479442
Keywords: fixed1.9.1 → verified1.9.1
Whiteboard: [fixed by bug 479442]
Target Milestone: --- → mozilla1.9.2a1

Comment 17

9 years ago
I disabled all add-ons and it still will not work. It works fine in the "older version" but not the "newer version". Should I try running safe mode? If so, how do I do that on a Mac?
Call it from the terminal like:
/Applications/Minefield.app/Contents/MacOS/firefox -safe-mode

Comment 19

9 years ago
Even in safe-mode it does nothing. Here again is my info: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090304 Firefox/3.0.6 ID:20090304022538
What version are you using? This user agent string looks completely broken. Firefox/3.0.6 doesn't match with rv:1.9.2a1pre. Can you please test with a fresh profile too? See: http://support.mozilla.com/en-US/kb/Managing+profiles

Comment 21

9 years ago
Ah, dont worry about that. I just changed that because a few sites were giving me problems because they didnt recognize the Minefield useragent tag. I changed it. I had this error before I changed this. I just tried clearing and trying a new profile and still nothing! Cant get it to work on my setup. My correct string is on Comment #14.

Comment 22

9 years ago
Looks like something on Gmail side. I have not working multiple attachments both with 3.0.7 and 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090304 Minefield/3.2a1pre
both in safe-mode and normal mode.. and after clearing google cookies.
Exactly multiple attachments works like single attachements. That is why i think something on gmail side.
multiple attachments enabled in gmail settings and Flash plugin works properly.

Updated

9 years ago
Keywords: fixed1.9.0.12
This is verified fixed for 1.9.0.12 with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.12) Gecko/2009070609 Firefox/3.0.12.
Keywords: fixed1.9.0.12 → verified1.9.0.12
You need to log in before you can comment on or make changes to this bug.