Save as automatically selects the whole filename for renaming, should exclude extension

RESOLVED DUPLICATE of bug 426680

Status

()

--
minor
RESOLVED DUPLICATE of bug 426680
10 years ago
10 years ago

People

(Reporter: xyseux, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; fr; rv:1.9.0.6) Gecko/2009011912 Firefox/3.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; fr; rv:1.9.0.6) Gecko/2009011912 Firefox/3.0.6

When the user selects "Save as", he's prompt a small window in which the filename is all selected (name.extension). Usually, the user is likely to change the name of the file, but likely to keep the extension as is.

It is time consuming to double-click the filename when a file needs to be saved on the user's desktop, it would advise to only highlight the filename, leaving the extension as is.

Reproducible: Always

Steps to Reproduce:
1. Open a webpage with pictures
2. Select Save As...

Actual Results:  
The filename is fully selected (name+extension)

Expected Results:  
The selection should be restricted to the name only (without the extension)
Isn't this an OS filepicker ?

Comment 2

10 years ago
Yes, it's an OS filepicker, but since other Mac apps get this right I assume the filepicker API makes it possible ;)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 426680
You need to log in before you can comment on or make changes to this bug.