Closed Bug 480537 Opened 12 years ago Closed 10 years ago

After landing of bug 425480, copied URL's from location bar are decoded and not meet RFC

Categories

(SeaMonkey :: Location Bar, defect)

defect
Not set
normal

Tracking

(blocking-seamonkey2.1 -, seamonkey2.1 wanted)

RESOLVED FIXED
Tracking Status
blocking-seamonkey2.1 --- -
seamonkey2.1 --- wanted

People

(Reporter: misak.bugzilla, Unassigned)

References

Details

(Keywords: regression)

copying http://ru.wikipedia.org/wiki/Пуштуны , and pasting it to another place/application should get http://ru.wikipedia.org/wiki/%D0%9F%D1%83%D1%88%D1%82%D1%83%D0%BD%D1%8B because decoded URL is not legal. In another word, we should encode URL before placing it to clipboard.
blocking-seamonkey2.1: --- → ?
Will not block a release, but it's surely wanted.
blocking-seamonkey2.1: ? → -
Neil, You still don't like the Firefox way? I can make patch, then we always can change it to something better.
Fixed in:
http://hg.mozilla.org/comm-central/rev/2ceaa8229eb1 (Bug 613199)
Status: NEW → RESOLVED
Closed: 10 years ago
Depends on: 613199
No longer depends on: 425480
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.