Closed Bug 480731 Opened 11 years ago Closed 11 years ago

Calendar events showing reminder after scheduled event instead of before

Categories

(Calendar :: Alarms, defect, major)

defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: fehe, Assigned: Fallen)

References

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Lightning/1.0pre 28-Feb-2009 04:33 PST

After an event with reminder is created, when checking the event, it show the reminder as being _after_ the scheduled event--even though the configured reminder was for _before_ the event.


Reproducible: Always

Steps to Reproduce:
1. Install Lightning on Shredder
2. Pick a date one month or more from today and create a new event with reminder "1 week before" (choose from reminder drop-down)
3. Save and Close
4. Double-click to open the event you just created
5. Notice that the reminder indicates "7 days _after_ the event starts"!
Version: unspecified → Trunk
Severity: critical → major
Confirming. Moreover this also happens with alarms "one day before" and "two days before". The rest of the standard-alarms seen to work ok.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-calendar1.0?
Flags: blocking-calendar1.0? → blocking-calendar1.0+
Assignee: nobody → philipp
Probably cause: the first entries of the dropdown list use |origin="before"| in calendar-event-dialog.xul. But the last three failing entries use |origin="1"|.
Attached patch Fix - v1 β€” β€” Splinter Review
Yes, this looks like the cause.
Attachment #367424 - Flags: review?(ssitter)
Comment on attachment 367424 [details] [diff] [review]
Fix - v1

r=ssitter
Attachment #367424 - Flags: review?(ssitter) → review+
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/25a5e9e27cc4>

-> FIXED
Status: NEW → RESOLVED
Closed: 11 years ago
OS: Windows XP → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Verified: Comment #1 also fixed.

Thanks
Status: RESOLVED → VERIFIED
Flags: blocking-calendar1.0+
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.