crashtest 421671.html triggers lots of asserts due to columns returning big min-width

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
3 years ago

People

(Reporter: bzbarsky, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [notacrash])

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
In particular, they return a min-width > unconstrained...

The issue is that there's a large column count here.

I'll attach a sorta-patch that doesn't help but points to a way to maybe try addressing this.
Why not just cap the min and pref widths at some value, say 1,000,000px? The only principled way out of this problem is floating-point coordinates anyway.

Updated

9 years ago
Whiteboard: [notacrash]
Testcase no longer asserts on trunk.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: in-testsuite+
Resolution: --- → WORKSFORME

Comment 6

3 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/1df2d92f4a86
status-b2g-v2.5: --- → fixed
removing the b2g 2.5 flag since this commit has been reverted due to an incorrect merge, sorry for the confusion
status-b2g-v2.5: fixed → ---
You need to log in before you can comment on or make changes to this bug.