Closed Bug 481097 Opened 13 years ago Closed 8 years ago

"ASSERTION: already started a batch!"

Categories

(Core :: DOM: Editor, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jruderman, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: assertion)

Attachments

(1 file)

Attached file stack traces
###!!! ASSERTION: bad action nesting!: 'mActionNesting>0', file /Users/jruderman/central/editor/libeditor/html/nsHTMLEditRules.cpp, line 390

###!!! ASSERTION: already started a batch!: '!mRootVM', file ../../../dist/include/view/nsIViewManager.h, line 352

I can't make a small, reliable testcase :(

I suspect the problem involves editor calling back into itself through an onresize event.
Probably related to, or a dupe of, bug 336091.
Depends on: 336091
The "already started a batch!" assertion was removed in Bug 598482 Part 15:
https://hg.mozilla.org/mozilla-central/rev/6d9721de770c

The "bad action nesting!" assertion is still there, but I will close this bug since the primary assertion has been removed. Please reopen if doing so is incorrect.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.