need to be able to clear msgWindow on a url

RESOLVED FIXED in Thunderbird 3.0b3

Status

MailNews Core
Backend
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Bienvenu, Assigned: Bienvenu)

Tracking

Trunk
Thunderbird 3.0b3
x86
Windows XP
Dependency tree / graph
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

9 years ago
Created attachment 365201 [details] [diff] [review]
proposed fix

nsMsgMailNewsUrl::SetMsgWindow doesn't do anything if the passed in msg window is null. For the auto config code, I need the ability to clear the msg window on a url. Patch upcoming.
Flags: blocking-thunderbird3+
Attachment #365201 - Flags: superreview?(bugzilla)
Attachment #365201 - Flags: review?(bugzilla)
Comment on attachment 365201 [details] [diff] [review]
proposed fix

do_GetWeakReference seems to cope with null values: http://mxr.mozilla.org/comm-central/source/mozilla/xpcom/glue/nsWeakReference.cpp#100

can't we just drop the if?
(Assignee)

Comment 2

9 years ago
Created attachment 365449 [details] [diff] [review]
fix addressing comment

right you are...
Attachment #365201 - Attachment is obsolete: true
Attachment #365449 - Flags: superreview?(bugzilla)
Attachment #365449 - Flags: review?(bugzilla)
Attachment #365201 - Flags: superreview?(bugzilla)
Attachment #365201 - Flags: review?(bugzilla)
Attachment #365449 - Flags: superreview?(bugzilla)
Attachment #365449 - Flags: superreview+
Attachment #365449 - Flags: review?(bugzilla)
Attachment #365449 - Flags: review+
(Assignee)

Comment 3

9 years ago
fix checked in.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Blocks: 481590

Comment 4

9 years ago
This regressed the MailNews Header-View, see Bug 481590. Sorry, but I don't know if this blocks or depends on the regression Bug, please correct this if I have set the wrong dependency.
I knew I was a bit cautious about this. TB and SM both showed the not marking newsgroup message as read issue, only SM showed the not displaying newsgroup headers properly issue.

I've backed it out for now whilst we look at this. The marking read issue seems to be that we set the message window to a value, then later in the protocol setup, it gets stamped over by setting it to null, because it doesn't have the message window at that stage.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 6

9 years ago
Well, it sounds like if it has a null msg window, it shouldn't set it...
(Assignee)

Comment 7

9 years ago
Created attachment 365675 [details] [diff] [review]
proposed fix

I'll run with the assertion for a while and see if I hit it unexpectedly - so far, I haven't seen it.
Attachment #365449 - Attachment is obsolete: true
Attachment #365675 - Flags: superreview?(bugzilla)
Attachment #365675 - Flags: review?(bugzilla)
Attachment #365675 - Flags: superreview?(bugzilla)
Attachment #365675 - Flags: superreview+
Attachment #365675 - Flags: review?(bugzilla)
Attachment #365675 - Flags: review+
(Assignee)

Comment 8

9 years ago
fix checked in with assertion still turned on for me - I'll remove it at some point...
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.