Tooltips must render onscreen and in front of the associated widget

RESOLVED WORKSFORME

Status

()

Core
XUL
P3
normal
RESOLVED WORKSFORME
18 years ago
16 years ago

People

(Reporter: Barry Marshall, Assigned: David Hyatt)

Tracking

Trunk
mozilla1.0.1
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(7 attachments)

(Reporter)

Description

18 years ago
Start Mozilla.  Maximize the window.
On Windoze, the graphical buttons on the lower-left corner don't display the
description of what they are.  With Netscape 4.x the description appears as a
popup over the icon.
If the window isn't maximized, the description appears below.
More than likely the code is putting the text description below the visible
portion of the window.
Is this a Theme or an XPToolkit bug?  Couldn't find a specific item to describe
the bug to put it under.

Comment 1

18 years ago
i see description of buttons when they are minimized in windows taskbar.
win32 98 #2000080804 PC
Created attachment 12600 [details]
Note the position of the pointer with Communicator
Created attachment 12601 [details]
See how Mozilla reacts when the pointer is in the same place.
Created attachment 12602 [details]
Eventually Mozilla kicks in the description.  Note pointer location.
Created attachment 12603 [details]
Now the browser is not maximized.  Note location of text placement with pointer location.
A couple of pictures to demonstrate what I'm talking about.  The moz0808-good 
and moz0808-bad are maximized.  The Taskbar is set to Auto-Hide.

I've tried switching skins and the behaviour seems consistent.

This happens on both Win NT4+SP6 and Win2000+SP1 with different video boards.
barrymarshall@home.com - this WORKSFORME in 20000819 WinNT4. Could you retest 
with a new build, please? :-)

Gerv
Component: User Interface: Design Feedback → XP Toolkit/Widgets
(Reporter)

Comment 8

18 years ago
Created attachment 13215 [details]
Problem still exists with 0821
(Reporter)

Comment 9

18 years ago
Nope, still happens.  This is Win2K + SP1, Takbar on Autohide.

Note that the problem is the position on the screen where the popup kicks in, 
not that it doesn't come up  (it does, but VERY low on the screen).

This can be confusing to a novice user.

Comment 10

18 years ago
Works fine on Mac, even when the buttons themselves are almost completely
off-screen. QA to Claudius. Can someone test on X?
Assignee: bdonohoe → trudelle
QA Contact: mpt → jrgm
Summary: Graphical launch buttons don't show text popup when window maximized → [Win] Tooltips can appear partially off-screen

Comment 11

18 years ago
Yes, on win2k with auto-hide of the windows taskbar, the tooltips for Nav, Mail,
etc. do not appear, possibly since they are popping up outside the monitor
dimensions. (Curiously, the tooltip for 'Open Windows' (bottom right) comes up
on screen).

On Mac, this works fine as mpt notes. On Linux they popup onscreen but are
almost immediately torn-down (so you can't actually read them).

This, however, is not something we can address in the near-term, and it is not a
major loss of functionality for the user. Setting Milestone -> Future.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Summary: [Win] Tooltips can appear partially off-screen → Tooltips can appear partially off-screen
Target Milestone: --- → Future

Comment 12

18 years ago
accepting for future
Status: NEW → ASSIGNED
(Reporter)

Comment 13

18 years ago
Tested against OS/2 0912 nightly build and problem appears here as well.
(Reporter)

Comment 14

18 years ago
Created attachment 14607 [details]
OS/2 variation on some more aspects of this weirdness.  Look how the description for the Mozilla site goes off the screen.
(Reporter)

Comment 15

18 years ago
Created attachment 14608 [details]
Compare this to Win32 0910
(Reporter)

Comment 16

18 years ago
Added additional observations on OS/2 weirdness of this problem, so I'm adding 
Mike Kaply on the cc list.

(Reporter)

Comment 17

17 years ago
Re-confirmed on Win32 1002.
SPAM

Reconfim under 1114.
Since he seems to be fixing tooltip problems, should this get assigned to Mike 
Pinkerton?

Comment 20

17 years ago
Can also repro on Win98 with collapsed win taskbar.  ->pinkerton, still future,
but worth fixing if trivial.
Assignee: trudelle → pinkerton
Status: ASSIGNED → NEW
(Reporter)

Comment 21

17 years ago
Reconfirm under 0409.

Nominate for 1.0.  This should be a pretty trivial bug, I would guess.
Keywords: mozilla1.0

Comment 22

17 years ago
*** Bug 78996 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Summary: Tooltips can appear partially off-screen → Tooltips must render onscreen and above the associated widget
Target Milestone: Future → ---

Comment 23

17 years ago
Tooltips in the taskbar for the components (Nav, Mail, IM, etc.) display below
the items, rendering them not visible when the application is maximized.  As
users have shown that they have a hard time finding other components, and the
maximized state is the default state, suggest we need to fix this for beta.
Keywords: nsbeta1
trudelle? what say you?

Comment 25

17 years ago
Restoring original summary. If we had a blanket rule of tooltips appearing 
above the control, that would cause almost as many problems as our current 
blanket rule of them appearing below the control.

Tooltips should follow the same positioning rule as context menus on Windows; 
appearing (in order of preference) to the southeast, southwest, northeast, or 
northwest.
Summary: Tooltips must render onscreen and above the associated widget → Tooltips can appear partially off-screen

Comment 26

17 years ago
Sorry, I meant above wrt ZOrder, not X/Y.
Summary: Tooltips can appear partially off-screen → Tooltips must render onscreen and in front of the associated widget
not a beta stopper, but would like to fix by rtm
Status: NEW → ASSIGNED
Keywords: nsbeta1 → nsbeta1-
Target Milestone: --- → mozilla0.9.2

Comment 28

17 years ago
Mac variation:

1. Start Mozilla
2. Enlarge window to almost touch bottom of screen.
3. Mouseover a component in the taskbar (Nav, Mail, IM, etc.)
4. Wait for tooltip to appear.
5. Without moving mouse, click on component button.

What happens:

Tooltip appears higher, so as to stay on the screen (good behavior), but appears
under mouse cursor and blocks the click from reaching the button under tooltip,
so nothing happens (bad behavior).

What should happen:

Component should be started.

Build Date and Platform: 2001050518 (Milestone 0.9) Mac OS 8.6

Related to bug 78248? or is this just a matter of offsetting the tooltip by one
pixel horizontally?
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Comment 29

17 years ago
> Tooltip appears higher [...] appears under mouse cursor and blocks
>  the click from reaching the button under tooltip

Confirm behavior under MacOS (2001070904): Should be fix. 


Target Milestone: mozilla0.9.3 → mozilla0.9.4
Target Milestone: mozilla0.9.4 → mozilla0.9.5
--> hyatt
Assignee: pinkerton → hyatt
Status: ASSIGNED → NEW
Target Milestone: mozilla0.9.5 → ---
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 31

16 years ago
On 2001121003 (maybe already some days earlier) and at least Windows 98 this bug
has changed/improved somehow, maybe due to changes in the code because of the
new IRC Chat Icon. The Tooltips for the icons in the lower left now show up in
the correct position, i.e. below the icons if there is enough space on screen
and in front of the icons if the window is streched to the bottom of the screen.

However, the Tooltips disappear within a half second, much to early to read them
them. But this gives this bug a new direction.

Comment 32

16 years ago
Defects do not go off in new directions.  Instead of trying to morph the bug
report to cover new defective behavior, file a new report.

Comment 33

16 years ago
OK. Then, how is the behaviour of the tooltips (for the icons in the lower left
corner) on other platforms than Win 98? If it is now the same as mentioned by me
for Win 98 I will mark this bug WFM an file a new one.

Comment 34

16 years ago
Editing for grammar.

Old Summary: Tooltips must render onscreen and in front of the associated widget

Old Summary: Tooltips must be rendered onscreen and in front of the associated
widget
Summary: Tooltips must render onscreen and in front of the associated widget → Tooltips must be rendered onscreen and in front of the associated widget

Updated

16 years ago
Summary: Tooltips must be rendered onscreen and in front of the associated widget → Tooltips must render onscreen and in front of the associated widget

Comment 35

16 years ago
This is almost certainly a duplicate of bug 73970.

Comment 36

16 years ago
Mike, you are right. But because the original issue on which this bug was about
(tooltips are out of screen because they show below of the buttons they belong
to) doesn't occur anymore (at least on Windows 98) I will mark this WORKSFORME.

Reopen if it does occur on other platforms than Windows 98 further on, but since
nobody replied to comment #33 I think its save to close this one.

The remaining issues with tooltips are covered from bug 73970.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.