Closed Bug 481478 Opened 12 years ago Closed 12 years ago

Update version mapping of nightly updates for Firefox 3.5/3.6

Categories

(AUS Graveyard :: Administration, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: nthomas, Assigned: morgamic)

References

Details

Attachments

(1 file)

Firefox 3.1 is going to become 3.5 when we do a b4, with trunk builds becoming 3.6. This patch accommodates that, and also cleans out old mappings which are no longer valid. We'll continue to push 3.5 (nee 3.1) snippets for nightly builds into the mozilla-1.9.1 dir, and 3.6 (nee 3.2) into the mozilla-central one.

All going well we'd be starting b3 today, and bumping the nightly app versions then, so the sooner the better to get this live.
Attachment #365505 - Flags: review?(morgamic)
Apparently we're not set in stone on this plan, and it will not be happening immediately. Lowering severity and removing review for the moment.
Severity: critical → normal
Attachment #365505 - Flags: review?(morgamic)
(In reply to comment #0)
> and also cleans out old mappings which are
> no longer valid.

You mean all the users on the old branches are screwed with no way to do automatic updates? That sounds ... wrong.
In the case of 1.5 there's nothing to update to because the machines have been off for months, the 1.* mapping applies to even older builds. 1.6a1 is also ancient.

We stopped using 4.0* for m-c on May 13 2008, if you haven't updated by now then tough, we need the head room for future versions.
Also, this only applies to *nightly* updates, not releases.
(In reply to comment #4)
> Also, this only applies to *nightly* updates, not releases.

Ah, ok.
Comment on attachment 365505 [details] [diff] [review]
Support 3.5/3.6 Firefox versions

The move to 3.5 is now confirmed, re-requesting review.
Attachment #365505 - Flags: review?(morgamic)
Note: We're going to coordinate a single day to make all changes, like this one. See: https://wiki.mozilla.org/Firefox3.1/3.5
Would immediately bumping 3.2a1pre to 3.6a1pre cause any problems? Trunk users are hardy folk.
(In reply to comment #7)
> Note: We're going to coordinate a single day to make all changes, like this
> one. See: https://wiki.mozilla.org/Firefox3.1/3.5

Think of this being a blocker to bumping the in-repo versions, as it'll ensure we have continuity for nightly updates. The change won't degrade anything that works now, so it can be in production before the big day and give us one less thing to co-ordinate. That sound OK ?

(In reply to comment #8)
> Would immediately bumping 3.2a1pre to 3.6a1pre cause any problems? Trunk users
> are hardy folk.

Yes, nightly updates would stop working.
(In reply to comment #9)
> Think of this being a blocker to bumping the in-repo versions, as it'll ensure
> we have continuity for nightly updates. The change won't degrade anything that
> works now, so it can be in production before the big day and give us one less
> thing to co-ordinate. That sound OK ?

Yep, sounds good.
Attachment #365505 - Flags: review?(morgamic) → review+
Filed bug 483248 for the prod push, otherwise it's checked in and ready to roll.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Depends on: 483248
Hey guys, I asked IT to wait until Monday to push this so we're not pushing Friday after-hours.  If that's waiting too long please escalate bug 483248 or ping me on IRC.  Thanks.
(In reply to comment #12)
> Hey guys, I asked IT to wait until Monday to push this ...

That's no worries at all.
You need to log in before you can comment on or make changes to this bug.