Firefox hung (?) on launching with JSSH extension

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
10 years ago
8 years ago

People

(Reporter: usharani.l, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01], URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.7) Gecko/2009021906 Firefox/3.0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.7) Gecko/2009021906 Firefox/3.0.7

Hi,

I use FireWatir on my Firefox to run some automation scripts. FireWatir requires the JSSh XPI which is installed on my Firefox default profile. I needed to run the scripts today, checked and found it wasn't selected by default, so launched Firefox manually with the JSSh extension:

$ /Applications/Firefox.app/Contents/MacOS/firefox -P firewatir -jssh & 

It did launch Firefox after I selected the "default" profile. But I couldn't type anything on any of the text fields or the browser address bar. It didn't seem to take any keyboard inputs though it seemed to take the mouse inputs (highlighting something with the mouse worked).

And strangely, I couldn't find this Firefox window which was open in front of me in the finder list of open applications (Force quite applications window or the tab list). Nor was it showing as open in the dock nor was the Firefox menu coming on the menu bar next to apple icon (it was showing the previous application menu instead).

And I couldn't open another Firefox instance.

I've two requests which I hope you guys can answer/solve quickly:

1. How do I make sure JSSh is always selected by default on my Firefox?
2. How do I get my Firefox working with JSSh? I can't use FireWatir otherwise.


Thanks,
Usha 

Reproducible: Always

Steps to Reproduce:
1. Install the JSSh 0.1

Once it is successfully installed (confirm doing a "telnet localhost 9997"):

2. Launch Firefox manually with JSSh typing this on the terminal:

 $ /Applications/Firefox.app/Contents/MacOS/firefox -P firewatir -jssh &

Now check...
Actual Results:  
As described above in Details.

Expected Results:  
As described above in Details.

I'm not sure what version of Firefox I had earlier. After this issue, I tried restarting my machine once and updated Firefox to 3.0.7, which didn't solve the problem either. I'm using Mac Leopard 10.5.5.

It was working before when I was regularly using it some weeks back on Firefox 3 as well as the earlier versions.
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.