addon versioning would ideally allow compatibility to be express in version ranges

RESOLVED DUPLICATE of bug 301236

Status

()

Toolkit
Add-ons Manager
--
enhancement
RESOLVED DUPLICATE of bug 301236
9 years ago
9 years ago

People

(Reporter: Leni, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6
Build Identifier: Thunderbird 3.0b2

It would be nice if addons could express finer-grained control over the version numbers of the applications with which it's compatible.

maxVersion and minVersion are good enough in general, but I would like the addon I am working on to:
- support Thunderbird 2
- support the latest Thunderbird 3 alpha or beta
- not support Thunderbird 3 releases prior to the current alpha/beta.
- not support -pre releases

By way of background: the addon makes extensive use of the addressbook API which is under heavy development.  So the addon is often broken when used in -pre releases or older alphas or betas.

As things stand, the addon has code to do this checking post-installation.  But users rightly complain "how come it let me install it in the first place!".

This leads to long and complicated explanations to users:
http://www.zindus.com/blog/2009/03/03/eudora-contact-sync/

If finer-grained version-compatibility meta-data could be explicitly expressed in installation manifests, it'd be much easier to manage.

Reproducible: Always
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 342963
Sorry, backend now, not website frontend
Duplicate of bug: 301236
You need to log in before you can comment on or make changes to this bug.