msnbc.com -- MSNBC header menu displays improperly, probably due to bad sniffing

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
10 years ago
a day ago

People

(Reporter: Portfolioso, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090305 Minefield/3.2a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090305 Minefield/3.2a1pre

The header menu on MSNBC.com does not display on one row on the Minefield trunk. It is not my screen resolution, because I also tested it on 3.0.6 and Chrome and it works fine.

Reproducible: Always

Steps to Reproduce:
1. Visit http://msnbc.com
2. Observe top navigation header
Actual Results:  
The sports link glitches down to the next line and is semi-hidden. Also, the MSN image seems to be duplicated. This does not happen in other browsers.

Expected Results:  
The menu items should be on one line and the MSN image should not repeat.

Comment 1

10 years ago
The sports link is also on the next line in Opera 10a1.
I also noticed in all browsers if the screen is narrower than the header, scrolling to the right shows no background behind the sports link making it almost invisible.
Component: General → Layout: Block and Inline
Product: Firefox → Core
QA Contact: general → layout.block-and-inline

Comment 2

10 years ago
I see the duplicated msn image at the very top right but not the other issue.  However, I can not click/hover over the head items to get the underlying menu except for the today show and nightly news header.
(Reporter)

Comment 3

10 years ago
I don't care what Opera does. We need to make sure Gecko displays it properly if Webkit can.

Comment 4

10 years ago
Bad sniffing strikes again:
Set your useragent to Firefox: the header is on one line
Set your useragent to something else (Minefield, Shiretoko, ...): the header is on two lines.

Comment 5

10 years ago
(In reply to comment #3)
> I don't care what Opera does. We need to make sure Gecko displays it properly
> if Webkit can.

We do care about the rendering of other browsers, that helps finding if the issue is browser specific or not.

Comment 6

10 years ago
I'm filling another bug for the duplicate background image.

Comment 7

10 years ago
Filed bug 481769 for the duplicate background. I'm morphing this bug into a tech evangelism one. The browser detection should deal with all Gecko browsers (if needed at all).

If someone could produce detailed report and contact the webmaster that would be great.
Assignee: nobody → english-us
Component: Layout: Block and Inline → English US
OS: Windows XP → All
Product: Core → Tech Evangelism
QA Contact: layout.block-and-inline → english-us
Hardware: x86 → All
(In reply to comment #4)
> Bad sniffing strikes again:
> Set your useragent to Firefox: the header is on one line
> Set your useragent to something else (Minefield, Shiretoko, ...): the header is
> on two lines.

I can't reproduce this in a recent Camino trunk nightly with the "Firefox" portion of the UA string removed. I get the navbar all on one line.

http://www.msnbc.msn.com/js/std.js

appears to be the script file hosting all their sniffing. They actually sniff for "Gecko" (although for some strange reason, they sniff for "Firefox" separately). I didn't bother investigating further than that, but someone else is more than welcome to.
(In reply to comment #2)
> I see the duplicated msn image at the very top right but not the other issue. 
> However, I can not click/hover over the head items to get the underlying menu
> except for the today show and nightly news header.

That is caused by that duplicated image (bug 481769). I nuked the li that contains the image with Firebug, as a result the whole navigation bar slides upwards (where it should be) and is clickable. Otherwise, the weather forecast widget covers the menu list and prevents clicking on some of the items.

I can't repro the other issue (wrapping) at any text size with
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090305 Minefield/3.2a1pre

Comment 10

10 years ago
Apparently, browser detection sets some classes on the body element, and different css rules apply that may put the header in two lines.

On Linux, with Useragent: 
Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
I get this class on the body:
class="Linux Firefox Firefox-3 Linux-Firefox"

If I change the UA to:
Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1b2) Gecko/20081201 Foo/3.1b2
I get this class on the body:
class="Linux Mozilla Mozilla-1 Linux-Mozilla"

When the "Firefox" class is there, the "margin-left" property on the "Today Show" <li> element is set, which prevents the text from wrapping.

I see the same issue on Windows.

Maybe on Mac the css classes are set differently and other rules match that may prevent the issue?
Since multiple people are seeing at least part of this issue, confirming. Who wants to send them a TE letter?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: MSNBC Header Menu Displays Improperly → msnbc.com -- MSNBC header menu displays improperly, probably due to bad sniffing

Comment 12

10 years ago
A bit late but I see the NBC Sports link split over two lines in Seamonkey.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090522 SeaMonkey/2.0b1pre - Build ID: 20090522031548

Comment 13

10 years ago
Created attachment 381848 [details]
Possibly related screenshot

Not sure if this is related but when a breaking news banner shows up, half is hidden.

Updated

10 years ago
Duplicate of this bug: 517372
No issue identified with this new site.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Component: English US → Desktop
Resolution: --- → WORKSFORME
Component: Desktop → Desktop
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.