Have unit tests (automation.py ones) dump stacks on crashes

RESOLVED FIXED in mozilla1.9.2a1

Status

Firefox Build System
General
RESOLVED FIXED
9 years ago
3 months ago

People

(Reporter: Benjamin Smedberg, Assigned: Benjamin Smedberg)

Tracking

({fixed1.9.1})

Trunk
mozilla1.9.2a1
x86
Linux
fixed1.9.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

9 years ago
Created attachment 365734 [details] [diff] [review]
Run minidump_stackwalk from automation.py, under the right conditions, rev. 1

This patch may be enough to have automation.py-style unit tests dump crash stacks.

Requirements:
* should have already run `make buildsymbols`
* should have MINIDUMP_STACKWALK=/path/to/minidump_stackwalk set in the environment

I'm not sure how/whether it will work with packaged tests... Ted is there a MDC doc on packaged tests?
Attachment #365734 - Flags: review?(ted.mielczarek)
No, but bug 421611 comment 36 explains how to do it with Mochitest.
(Assignee)

Updated

9 years ago
Blocks: 481495
(Assignee)

Comment 2

9 years ago
Created attachment 366015 [details] [diff] [review]
Run minidump_stackwalk from automation.py, under the right conditions, rev. 1.1

Minor path fixup discovered during tinderbox testing
Attachment #365734 - Attachment is obsolete: true
Attachment #366015 - Flags: review?(ted.mielczarek)
Attachment #365734 - Flags: review?(ted.mielczarek)
Attachment #366015 - Flags: review?(ted.mielczarek) → review+
Comment on attachment 366015 [details] [diff] [review]
Run minidump_stackwalk from automation.py, under the right conditions, rev. 1.1

+    mkdir $(DIST)/crashreporter-symbols

Should probably be $(NSINSTALL) -D while you're here.

+    cd $(DIST)/crashreporter-symbols && \
           zip -r9D ../../$(SYMBOL_ARCHIVE_BASENAME).zip .

You need to take out one ../ in the zip file name there.

+    log.info("TEST-UNEXPECTED-FAIL | Browser crashed (minidump found)")

can you make this say:
TEST-UNEXPECTED-FAIL | automation.py | Browser crashed (minidump found)

In the tinderbox summary, this should work out ok, right? the crash stack will wind up right below this, and both should wind up in the short log?

It'd be nice if you added cmdline args to runtests.py / runreftest.py to specify the symbol path, since we're gonna need that eventually anyway.
(Assignee)

Comment 4

9 years ago
http://hg.mozilla.org/mozilla-central/rev/a2a7177a218e
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 387555
Depends on: 483388
Flags: wanted1.9.1?
Target Milestone: --- → mozilla1.9.2a1
Version: unspecified → Trunk
Flags: wanted1.9.1? → wanted1.9.1+
Depends on: 493371

Updated

3 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.