Have to change content type / action to save file before always ask works

RESOLVED DUPLICATE of bug 480242

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 480242
10 years ago
2 years ago

People

(Reporter: MrSmite, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7 (.NET CLR 3.5.30729)

The default action for PDF content is "Use Adobe Reader in Firefox" however I
wanted to switch it to "Always ask".

After switching to "Always ask", it still opened the PDF in my browser. I closed
and reopened all Firefox windows, checked that "Always ask" was still selected
for PDF and it still opened the PDF in my browser.

In order to solve the problem, I had to switch the option to "Save File" and
download at least one PDF document. After this I switched it back to "Always ask" and Firefox finally honored the setting by prompting me when I clicked a
PDF document.

Note: This symptom occurred with both Adobe Reader 6 and Adobe Reader 9. In both
cases I have turned off the view PDF in browser option within Adobe Reader itself.

Reproducible: Always

Steps to Reproduce:
1. Change the default setting for PDF from "Use Adobe Reader in Firefox" to "Always Ask"
2. Click a PDF document
3.
Actual Results:  
It will open in a new tab (or window depending on your Firefox settings)

Expected Results:  
You should get a dialog asking if you want to open or save the file

As I mentioned in my description, if you switch the option to "Save File" and
download at least one PDF document, you can then switch it to "Always Ask" and
Firefox will honor your setting.

Note: This also happens for ZIP files or pretty much any content type. You
simply can't switch to "Always Ask" without switching to "Save File" first.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 480242
You need to log in before you can comment on or make changes to this bug.