browser.link.open_newwindow = 1 does not open external links in the same tab

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: notify_craig, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6

My understanding is that when I set browser.link.open_newwindow = 1 all "external" links--ones I click on from programs outside of Firefox--should open in the same tab.  Instead, they still open in a new tab.

Reproducible: Always

Steps to Reproduce:
1. open Firefox
1a. make sure F.F is the default browser
2. go to about:config
3. filter by "window"
4. change browser.link.open_newwindow value to 1
5. close browser (not sure what makes this value persistent)
6. open browser
7. in a separate application, click on a hyperlink


Actual Results:  
Hyperlink opens in a new F.F. tab.

Expected Results:  
Hyperlink should open in the same F.F. tab.

I have some add-ons installed:

Firebug 1.3.3
Java Quick Starter 1.0
LogMeIn 1.0.0.406
Mouse Gestures 2.0.3

Build config:

about:buildconfig

Build platform
target
i686-pc-mingw32

Build tools
Compiler 	Version 	Compiler flags
cl 	14.00.50727.762 	-GL -wd4624 -wd4952 -TC -nologo -W3 -Gy -Fd$(PDBFILE)
cl 	14.00.50727.762 	-GR- -GL -wd4624 -wd4952 -TP -nologo -Zc:wchar_t- -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-optimize --disable-debug --disable-tests --enable-update-packaging --enable-official-branding --enable-jemalloc --with-crashreporter-enable-percent=10
(Reporter)

Comment 1

8 years ago
I played with browser.link.open_newwindow.restriction just to see, but it didn't make any difference.

Also, I ran in safe mode (firefox.exe -safe-mode) and selected "Disable all Add-Ons" but that didn't help either.
Hmm, AFAIK, it's browser.link.open_external setting that will control external links and browser.link.open_newwindow (and .restriction) is only for links clicked inside Firefox itself.

Comment 3

8 years ago
browser.link.open_external does not work either in 3.5.
Yeah, I noticed. Luckily there's a handy add-on in bug 469082 that fixes this bug (by bringing back browser.link.open_external) since it probably won't get fixed because core devs seems to be thinking that this is the right way to go. :(
(Reporter)

Comment 5

8 years ago
Right way to go??  IMO, it should be going even more the other way: Browsers should be evolving to have more intelligence--and complementary user options--around tabs and when to create new ones.  For instance, I think it would be great to be able to turn on an option where a newly requested URL opens in the current tab if the current tab contains a page with the same TLD as the requested URL, and conversely, it opens in a new tab if its TLD is different.  Does anyone see a problem with browser starting to adopt this can of behaviour (as an option)?
(Reporter)

Comment 6

8 years ago
This appears to be fixed in version 3.5 but I don't know the accepted protocol for updating the status.  Should I mark it Resolved?

Comment 7

8 years ago
Yeah, since we don't know which exact changeset changed the behavior fixed, it's RESOLVED/WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.