Closed Bug 481912 Opened 12 years ago Closed 12 years ago

Toolbar Icons Disappear if moved to main Menu bar line

Categories

(Firefox :: Toolbars and Customization, defect)

3.5 Branch
x86
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 447571

People

(Reporter: rajiv001, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1b3pre) Gecko/20090304 Shiretoko/3.1b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1b3pre) Gecko/20090304 Shiretoko/3.1b3pre

I Combine the navigation bar and Bookmarks bar with one liner Main Menu bar which has Menu items, NAvigation Buttons, Bookmarks and URL and serach bars all in one top line. 

And every time I open Firefox 3.1 beta 2 or Beta 3 all the additional icons from Bookmark Bar (on the top menu line itself) disappear and are shown with a ">>" mark - which can be expanded and seen. 

To get the Icons/Bookmarks back in the same line without creating the shorcut icon ">>" I just have to right click on the toolbars, open the customize dialog and just close it. Then all Icons/Bookmarks stay in one line. 

This didn't happen with firefox 3.0.x, it only happens with all versions of 3.1 Betas 

Reproducible: Always
Similar to Bug # 499755

Reproducible: Always

Steps to Reproduce:
1. Move Icons from navigation bar and Bookmarks bar to the Main Menu bar which has Menu items, NAvigation Buttons, Bookmarks and URL and serach bars all in one top line. 

2. Open Firefox 3.1 beta 2 or Beta 3 all the additional icons from Bookmark Bar (on the top menu line itself) disappear and are shown with a ">>" mark - which can be expanded and seen as a drop down. 

3. To get the Icons/Bookmarks back in the same line without clicking the shorcut icon ">>" , right click on the toolbars, open the customize dialog and just close it. Then all Icons/Bookmarks stay in one line. 


Actual Results:  
Icons gets combined and are shown as ">>" icon which when click displays all icons correctly

Expected Results:  
Should maintain the position of Icons as long as there is enough space in the Main Menu bar (which happens if we click and open customize and close customize without doing anything).

This a great featute to move all Bars/Icons on one line and would like to use it as we are able to in our existing 3.0.x verions.
Summary: Toolbar Icons Disapper if moved to main Menu bar line → Toolbar Icons Disappear if moved to main Menu bar line
Version: unspecified → 3.1 Branch
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 447571
You need to log in before you can comment on or make changes to this bug.