Last Comment Bug 481962 - Force logging on in imagelib
: Force logging on in imagelib
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla8
Assigned To: Justin Lebar (not reading bugmail)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-06 15:49 PST by Joe Drew (not getting mail)
Modified: 2011-07-13 15:27 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Force logging in build rather than in code (416 bytes, patch)
2009-03-06 15:49 PST, Joe Drew (not getting mail)
vladimir: review+
Details | Diff | Splinter Review
Force logging everywhere in build (9.81 KB, patch)
2009-03-09 10:50 PDT, Joe Drew (not getting mail)
vladimir: review+
Details | Diff | Splinter Review
Patch v1 (7.41 KB, patch)
2011-07-08 10:22 PDT, Justin Lebar (not reading bugmail)
joe: review+
Details | Diff | Splinter Review

Description Joe Drew (not getting mail) 2009-03-06 15:49:55 PST
Created attachment 366032 [details] [diff] [review]
Force logging in build rather than in code

We need to have logging forced on, even in release builds. It's impossible to debug problems users have without it.
Comment 1 Vladimir Vukicevic [:vlad] [:vladv] 2009-03-06 16:35:02 PST
Comment on attachment 366032 [details] [diff] [review]
Force logging in build rather than in code

I don't think you even need the ifneq bit.. no reason not to just -DFORCE_PR_LOG unconditionally
Comment 2 Joe Drew (not getting mail) 2009-03-09 10:50:12 PDT
Created attachment 366333 [details] [diff] [review]
Force logging everywhere in build

Turns out we need to add the logging bit to just about every Makefile.

Are you sure about -DFORCE_PRLOG everywhere, regardless of whether MOZ_LOGGING is on? Are we going to run into build problems in a build where logging is forced off?
Comment 3 Vladimir Vukicevic [:vlad] [:vladv] 2009-03-11 08:51:57 PDT
Comment on attachment 366333 [details] [diff] [review]
Force logging everywhere in build

I don't see how it would, but ask ted?
Comment 4 Ted Mielczarek [:ted.mielczarek] 2009-03-11 10:28:17 PDT
The only point of MOZ_LOGGING, it would appear, is to control whether various modules define FORCE_PR_LOG. It looks like everywhere else in the tree just does:
#if defined(MOZ_LOGGING)
#define FORCE_PR_LOG
#endif

http://mxr.mozilla.org/mozilla-central/search?string=MOZ_LOGGING

Do you not have a central header you could do this in? If not, maybe instead you could add MOZ_LOGGING=1 here:
http://mxr.mozilla.org/mozilla-central/source/configure.in#6461

and then AC_SUBST(MOZ_LOGGING) down with the other AC_SUBST bits, add it to autoconf.mk.in, and just use it as a makefile var:
ifdef MOZ_LOGGING
...
endif
Comment 5 Justin Lebar (not reading bugmail) 2011-07-06 20:55:46 PDT
Is this still something we want?  I'd kind of like it for bug 666352 (although there, I really only care about having it on during my custom release builds, not official builds).
Comment 6 Joe Drew (not getting mail) 2011-07-07 08:54:09 PDT
Yes, we definitely still want this.
Comment 7 Justin Lebar (not reading bugmail) 2011-07-08 10:22:15 PDT
Created attachment 544848 [details] [diff] [review]
Patch v1

This forces logging on within ImageLogging.h.  This is similar to how nsHttp.h works.
Comment 8 Joe Drew (not getting mail) 2011-07-12 07:36:50 PDT
Comment on attachment 544848 [details] [diff] [review]
Patch v1

If'n this passes try, hooray!
Comment 9 Justin Lebar (not reading bugmail) 2011-07-12 14:30:23 PDT
Try push: http://hg.mozilla.org/try/rev/144138c0b56d
Comment 10 Justin Lebar (not reading bugmail) 2011-07-13 08:19:59 PDT
Inbound: http://hg.mozilla.org/integration/mozilla-inbound/rev/0c69c4d8e19e

Note You need to log in before you can comment on or make changes to this bug.