The default bug view has changed. See this FAQ.

Myspace music player does not appear (but music plays) after clicking blocked Flash icon

RESOLVED WORKSFORME

Status

Camino Graveyard
Annoyance Blocking
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Smokey Ardisson (offline for a while; not following bugs - do not email), Unassigned)

Tracking

Details

(URL)

One of our users reported in the forum that recently (in the past 2 weeks), clicking on a Myspace music player starts to play the music but fails to display the player.  I can reproduce this in Firefox with 1.5.8, and in Camino 1.6.x and 2.0* with either 1.5.7 or 1.5.8.

The problem seems to be that the Flash <object> looks like this (in DOMI; source via the "Copy XML" context menu item) when Flashblock is not used:

<OBJECT width="450" height="345" align="middle"
        classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
        name="shell" id="shell" style="visibility: visible;">
     [...]
     <OBJECT width="450" height="345" align="middle"
          data="http://lads.myspace.com/videos/Main.swf"
          type="application/x-shockwave-flash">
          [...]
     </OBJECT>
</OBJECT>

Note the 'style="visibility: visible;"' there (it's not in the actual page source, but DOMI insists it's part of the DOM node, if you look at DOM Node in DOMI).

When you're using Flashblock and the <object> is restored after click, there's no 'style="visibility: visible;"' showing up in the DOM Node viewer for the restored <object>.

My guess is that the style is being set initially from http://x.myspacecdn.com/modules/common/static/js/swfobject-15_pba8crsx.js ?
Flags: camino1.6.7?

Comment 1

8 years ago
Over here with Firefox 3.0.7 and Minefield (3.2a1pre) in safe-mode the player is invisible too.

Could you retest with Firefox with either Flashblock uninstalled or in safe mode and tell me what you see?

Comment 2

8 years ago
The player appears to be invisible with Firefox 2.0 in safe mode as well. the DOMI shows that the outer object (box model) has a height of 14px.

Comment 3

8 years ago
I guess that the reason people without Flashblock aren't complaining is that they are not aware that there is a MP3 player there at all given that the outer object is basically a thin flat line.

Ugh! Oh look! IE conditional comments!

<div id="profile_mp3Player" style="width: auto; height: auto;">
	<object style="visibility: visible;" id="shell" name="shell" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" align="middle" height="345" width="450">
		<param name="movie" value="http://lads.myspace.com/videos/Main.swf">
		<param name="quality" value="high">
		<param name="wmode" value="transparent">
		<param name="allowscriptaccess" value="always">
		<param name="flashvars" value="....">
		<!--[if !IE]>-->
		<object type="application/x-shockwave-flash" data="http://lads.myspace.com/videos/Main.swf" align="middle" height="345" width="450">
			<param name="quality" value="high">
			<param name="wmode" value="transparent">
			<param name="allowscriptaccess" value="always">
			<param name="flashvars" value="....">
			<!--<![endif]-->
				<div id="flGtFlMJV"><blockquote>Oops!  In order to listen to this, you will need to enable JavaScript and install Adobe Flash 9 or greater.  <a href="http://www.macromedia.com/go/getflashplayer/">Get Flash now!</a></blockquote></div>
			<!--[if !IE]>-->
		</object>
		<!--<![endif]-->
	</object>
</div>

Comment 4

8 years ago
I tried this with a variety of browsers (Safari 3 & 4b, Opera 10a and 9.64, Firefox 3.07 with a default profile, Minefield with a flashblock free profile) and that movie player is essentially invisible everywhere.

And I didn't get any sound.

But you're right that with FlashBlock (and after clicking on the placeholder), the outer <object> is still set to visibility:hidden (injected via the script: the generated source bookmarklet reveals a style block just before the opening <body>).

PS - those conditional comments just say 'if not IE'.
I see the player displayed on (or slightly after, depending on network load) pageload in both a fresh profile and Safe Mode in Firefox 3.0.x.  This is the same behavior I see when I'm running a normal profile with Flashblock disabled, or a normal profile with Flashblock enabled but Myspace.com whitelisted(! scary!).

I have no idea why you don't see that player?

Comment 6

8 years ago
(In reply to comment #5)
 
> I have no idea why you don't see that player?

Flash 10 ?
I just tried with Camino 1.6.6ml, running on OS X 10.3.9 & Flash 9 r151.
With Flashblock --> no player visible, but sound coming out.
With Flashblock disabled --> player & sound.

On 10.5.6 & Flash 10.r22, the browsers mentioned in comment 4 just display a black hole where the player should be. And NO sound.

Comment 7

8 years ago
cc someone from Adobe since this might be a Flash 10 problem. Michelle please forward this to the right person.
(In reply to comment #6)
> On 10.5.6 & Flash 10.r22, the browsers mentioned in comment 4 just display a
> black hole where the player should be. And NO sound.

I have Flash 10.0r22, too; in addition to checking with Firefox 3.0.7 with no Flashblock/Safe Mode in comment 5, I checked Safari 3.2.1 and Opera 9.6.4, and they all show the player (and the sound).  hendy and cl both saw the player in the no-Flashblock or MySpace-whitelisted scenario, too.  /me more puzzled....

Comment 9

8 years ago
Well I'm on WinXP/SP2 and Flash 10.0. With Firefox 2.0, 3.0, Shiretoko, and Minefield in safe mode, the Myspace flash player is invisible.

Comment 10

8 years ago
Could MySpace be using geo-location and serving different content to different parts of the world? In the past I have been unable to resolve certain user problems since the relevant website was serving up different content to non-US viewers.
(In reply to comment #10)

It does, the linked page is served in Japanese (happen to live there). That wouldn't explain why I see the Flash movie on one machine but not the other (see comment 6).
Flags: camino1.6.7? → camino1.6.7-
Flags: camino1.6.8?
Flags: camino1.6.8? → camino1.6.8-

Comment 12

8 years ago
I've solved this problem creating a GreaseMonkey Script containing :



// ==UserScript==
// @name           Afficher Player
// @namespace      Gmail
// @include        http://www.myspace.com/*
// ==/UserScript==


document.getElementById("profile_mp3Player").addEventListener('click', function(event) {
	setTimeout("document.getElementById(\"shell\").style.visibility=\"visible\"",500);
}, true);



This could maybe help you to understand what doesn't work, the inline style element "visibility" isn't overridded with "visible" as it it is without FlashBlock.

Comment 13

8 years ago
So as an experiment in the function flashblockShowFlash() after the line that says:
	parent.removeChild(placeholder);

Add the following line:
	parent.style.setProperty("visibility", "visible", "important");

Comment 14

8 years ago
Hmm that won't work since "profile_mp3Player" is a parent container to the actual flash object. I would guess that with flash objects dynamically created with javascript, the JS fails to find the flash object removed by flashblock and then it falls over and fails to turn on the visibility of the parent division.

Comment 15

8 years ago
Running 3.0.10 with Flash Player r22.87 I cannot reproduce this with Mac OSX 10.4.11.  I see the music player play in the upper right corner.

Any additional information?

Comment 16

8 years ago
According to this comment in the related mozdev bug:

> I think this is not a bug, here at least: I've solved it for one user/system by
> changing one of the settings in Adobe Flash Player.

> Details:

> We had one affected Windows XP Home box with 2 main users, one uses Flashblock
> and had this issue, one does not use Flashblock and never hit this issue.  The
> issue was reproduced with Google Chrome on the affected account.

> The resolution was to change settings in the Adobe Flash Player Settings
> Manager
> (http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager04.html)
> and in "Global Security Settings" switch from "Always deny" to "Always ask". 
> The FIM Media Player on MySpace does not ask, but now works.

So it might be worth it to compare the Flash player security settings on those computers where this bug exists vs those where this bug doesn't manifest itself.
Fwiw, it didn't make any difference here. Camino latest nightly and Minefield latest nightly fail to load the player when FlashBlock is on.

My original settings: 'always ask'. I looped through all 3 prefs, and even quit-restarted the browser(s). But each time I only saw a black hole (kinda like that black hole btw - their player is ugly </polite voice>).

The one difference with my previous comments is that without Flashblock the player is actually visible in all browsers now.

Comment 18

8 years ago
Hmm. What happens if you allow Third Party Flash content to store data on your computer in the Flash global storage settings? (I'm paranoid so I dare not allow this even in my test profile).

<http://forums.myspace.com/p/4422138/58074351.aspx?fuseaction=forums.viewpost#58074351>

Comment 19

8 years ago
> Hmm. What happens if you allow Third Party Flash content to store data on your
> computer in the Flash global storage settings? (I'm paranoid so I dare not
> allow this even in my test profile).

Wow! I temporarily allowed this and the FIM player worked when I clicked on the Flashblock placeholder! And I didn't change any Flashblock code. I've since changed it back to disallow. Note I had the amount of disk space to allow websites to store data set to None so I couldn't find any flash cookies on my HD after that so it looks like the FIM player doesn't actually need to store data on your HD but just checks for access.

Comment 20

7 years ago
Allowing local storage for Flash Player fixes the issue.  Closing.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.