If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Show Cookies…" button is broken

RESOLVED DUPLICATE of bug 458539

Status

Camino Graveyard
Preferences
RESOLVED DUPLICATE of bug 458539
9 years ago
9 years ago

People

(Reporter: Markus Amalthea Magnuson, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
When I click the "Show Cookies…" button in the Privacy prefpane, nothing happens, and I get this message in the console:

Mozilla has caught an Obj-C exception [NSInvalidArgumentException: *** -[NSCFArray insertObject:atIndex:]: attempt to insert nil]

This is on Camino 2.0b2.

Comment 1

9 years ago
This sounds the same as bug 458539. Can you try with a nightly build ?
(Reporter)

Comment 2

9 years ago
Yes, everything works as normal in the latest nightly build. If beta2 is in its own branch now I guess the patch needs to be applied there too.

Comment 3

9 years ago
(In reply to comment #2)
> Yes, everything works as normal in the latest nightly build. If beta2 is in its
> own branch now I guess the patch needs to be applied there too.

It's not; we just didn't discover the problem in time to get the fix into b2.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 458539

Comment 4

9 years ago
By the way, if you're interested in figuring out what site is setting cookies with a null name, look in the cookies list with a nightly for "<null>" in the Name column. When you figure it out, let the site know they're in violation of the cookies RFCs and that they should set a name when they set that cookie.
You need to log in before you can comment on or make changes to this bug.