Cookie dialog does not display properly when visting cnn.com the first time

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
10 years ago
3 years ago

People

(Reporter: marcia, Unassigned)

Tracking

1.9.1 Branch
x86
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 366340 [details]
Screenshot of cookie dialog

Seen while running Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3

STR:
1. Launch Private Browsing mode.
2. Go into Cookies Preferences and switch to "Ask me every time"
3. Load CNN.com
4. Observe the dialog I get the first time

After this initial load and I allow the first cookie, this dialog goes away. I have also seen this several other times during my testing, both in regular browsing mode and Private Browsing mode. It is difficult to reliably reproduce it.
Here is the Litmus test I was running when I saw this most recently: https://litmus.mozilla.org/show_test.cgi?id=7397
I *think* prefs are not saved in PB mode, I may be wrong.
No idea if this is related but I've seen an empty security warning dialog too when opening a site with an untrusted ssl cert. When I confirmed the exception the dialog has no text in there.
Does this happen on 1.9.0.x?
Olli, we saw those half-filled dialog boxes during our FFT testing on Firefox 3.1 Beta 3. I have no idea if this also happens on the 1.9 branch. I haven't seen it with latest Shiretoko builds at all since a month.
no longer have ask me every time
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.