Successful group submission needs mission statement to have 28 words and not 25 as mentioned in the user message

VERIFIED WONTFIX

Status

VERIFIED WONTFIX
10 years ago
7 years ago

People

(Reporter: krupa.mozbugs, Assigned: mary)

Tracking

unspecified
x86
Windows XP

Details

(Whiteboard: strings, URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 366414 [details]
group body with 25 words

Steps to reproduce:

1.Go to https://spreadfirefox.authstage.mozilla.com
2.Log in to your admin account
3.Create content->Project.
4.Try to submit a project with exactly 25 words.

expected result:
submission is successful with 25 words or the user message stats is revised

accepted result:
For submission to be successful the mission statement needs to min 28 words long.
(Assignee)

Updated

10 years ago
Assignee: nobody → paul

Comment 1

10 years ago
If this problem exists then it is a problem with the core node module. Does this problem also occur without the FCK Editor disabled?

Comment 2

10 years ago
From the node module ....

// Make sure the body has the minimum number of words.
  // todo use a better word counting algorithm that will work in other languages
  if (isset($node->body) && count(explode(' ', $node->body)) < $type->min_word_count) {
    form_set_error('body', t('The body of your @type is too short. You need at least %words words.', array('%words' => $type->min_word_count, '@type' => $type->name)));
  }


It looks as though there may be a problem with the counting algorithm. 

Shall we resolve this as WONTFIX since even if the problem can be reproduced anf fixed were not going to be making modifications to drupal core. 

Passing this back to you Mary to manage the resolution of this bug.

Best, Paul
Assignee: paul → mary
if we're not changing how many words are actually required we should try and override the string to reflect
Whiteboard: strings
(Assignee)

Comment 4

10 years ago
Paul:  Can you handle this?  Thanks!
(Assignee)

Comment 5

10 years ago
Paul...Checking in here.

Comment 6

10 years ago
I couldn't reproduce this bug. As soon i submitted a post with exactly 25 words i didn't get the warning message.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 7

10 years ago
Paul,
I was able to reproduce this.Can you please try again with the test data that I have used?

The bug seems to have mutated in its month of existence. I can now submit a project with 25 words if all the words are in the same sentence. But if a user's content is in 3 distinct lines,submit is still unsuccessful.


screencast:http://screencast.com/t/eg9c0e0K0A9
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
This happens because we have a WYSIWYG editor that adds tags (e.g. <p>) which messes up the normal word counting alg.

I don't think this is worth spending time to try and fix.  25, 28, only a 3 word difference, most people probably won't even notice.

Paul, if you know of a simple way to fix this, go for it, but it doen't have to be a huge time sink.  I'd rather just mark wontfix

Comment 9

10 years ago
I agree Alex, it's a very small problem something that core know about and are working on so i would say we should mark it as WONTFIX and wait for it to be fixed upstream.
(Assignee)

Updated

10 years ago
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 10

10 years ago
verified
Status: RESOLVED → VERIFIED
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.