Closed Bug 482549 Opened 15 years ago Closed 15 years ago

[Mac] Localized date of last modification of page is not shown

Categories

(Core :: Internationalization, defect)

1.9.1 Branch
x86
macOS
defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla1.9.2a1

People

(Reporter: zloy, Assigned: smontagu)

References

Details

(Keywords: fixed1.9.1, intl, Whiteboard: [fixed by bug 360018])

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.7) Gecko/2009021906 Firefox/3.0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.7) Gecko/2009021906 Firefox/3.0.7

Error !! Mozilla on English for Mac Os X not show modified date of www 
sorry for my english

Reproducible: Always




Error !! Mozilla on English for Mac Os X not show modified date of www
Sorry but you have to explain what do you mean with modified date and what do you mean with www. Please add steps to reproduce..
Confirm this bug for Firefox 3.1b3 (Russian)

>Please add steps to reproduce..
1. Open any page in Firefox
2. Navigate to Tools - Page Info
3. Switch to General tab
4. Look on Modified item 

Actualy you can see only week day short name like Пт (short form for 	
Friday on Russian).  Look attached screenshort.
Attached image Page Info screenshort
Alexey: This works for me with FF3.0.7 (english) on a german vista system.
Does this only happen in the russian version ?
> on a german vista system
This bug only for Firefox on Mac OS X.
On Linux and Windows displays date correctly
Looks like this bug was caused by Bug 368838 or Bug 476419
Keywords: intl
(modified from pageInfo.js)
var sLocale = "";
var date = new Date();
var dateService = Components.classes["@mozilla.org/intl/scriptabledateformat;1"]
                            .getService(Components.interfaces.nsIScriptableDateFormat);
dateService.FormatDateTime(sLocale, dateService.dateFormatLong, dateService.timeFormatSeconds,
                           date.getFullYear(), date.getMonth()+1, date.getDate(),
                           date.getHours(), date.getMinutes(), date.getSeconds());

results:
1. sLocale = "en-US"
"Wed, Mar 18, 2009 9:46:49 PM"
  
2. sLocale = "ru-RU"
Only "Ср" (Wed in Russian)

3. sLocale = ""
Depend on system locale. "ë", for example.
Severity: trivial → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: wanted-firefox3.5?
Summary: Error !! Mozilla on English for Mac Os X not show modified date of www → [Mac] Localized date of last modification of page is not shown
Confirming, based on last reports.
From what I can tell, nsIScriptableDateFormat and Date.toLocaleString() don't share any code so this bug is different from bug 368838/bug 476419. This bug is in the wrong product however, moving to Core.
Assignee: nobody → smontagu
Component: Page Info → Internationalization
Flags: wanted-firefox3.5?
Product: Firefox → Core
QA Contact: page.info → i18n
Version: unspecified → 1.9.1 Branch
In a trunk build the javascript in comment 7 gives me
1. sLocale = "en-US"
"March 19, 2009 12:34:46 AM"
2. sLocale = "ru-RU"
"19 марта 2009 г. 0:36:38"

This was probably fixed by bug 360018.
I think you are right, I hope somebody can confirm that this issue is fixed on trunk. The new code looks good and I don't see any obvious issues there. Do you want to request approval for 1.9.1?
Yes, now that it has baked on trunk for a few days.
Depends on: 360018
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090318 Minefield/3.6a1pre
Looks good.

sLocale = "ru"
19 марта 2009 г. 11:23:43

sLocale = "en"
March 19, 2009 11:23:48 AM

sLocale = ""
19 марта 2009 г. 11:23:58

$ locale -k LC_TIME | grep "^mon"
mon="января";"февраля";"марта";"апреля";"мая";"июня";"июля";"августа";"сентября";"октября";"ноября";"декабря"
Do you also see the correctly formatted date in the Page Info dialog itself?
Yes.
Maybe that should be WORKSFORME but I am resolving as FIXED because we know that this was fixed in bug 360018 (not 100% confirmed but looking at the patch I am pretty certain of that).
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Marking verified fixed for trunk based on comment 13. Can anyone please verify that it is also fixed on 1.9.1 please?
Status: RESOLVED → VERIFIED
Keywords: fixed1.9.1
Whiteboard: [fixed by bug 360018]
Target Milestone: --- → mozilla1.9.2a1
You need to log in before you can comment on or make changes to this bug.