too small textbox for custom snooze time in reminder dialog causes confusion what snooze time is uses

RESOLVED FIXED in 1.0b1

Status

defect
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: mozilla, Assigned: ssitter)

Tracking

unspecified
1.0b1

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7 (.NET CLR 3.5.30729)
Build Identifier: Thunderbird 3.0b2 / Lightning 1.0pre 2009-03-07 / WinXP sp3

Reminders snooze for fifteen minutes instead of one

Reproducible: Always

Steps to Reproduce:
1) Create an event with a start time in the near future.
2) Set a custom reminder for one minute before the start time.
3) When the reminder fires, click the "Snooze All For" button and set a custom snooze time of one minute.

Actual Results:  
The reminder re-appears after fifteen minutes.

Expected Results:  
The reminder should re-appear after one minute.

I'm using a local ics file.

In Lightning's options, the default reminder time is one hour, so this bug's problem seems unrelated to that.

I'm setting the bug's priority to Major because this behavior could cause people to be late for important events.
(Assignee)

Comment 1

10 years ago
Works fine for me using Lightning 1.0pre (BuildID: 20090310032307) with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090310 Shredder/3.0b3pre (BuildID: 20090310031252) and local ics file:

After creating the alarm:

[calAlarmService] considering alarm for item: New Event alarm time: 2009/03/10 22:22:00 UTC isDate=0 snooze time: null
[calAlarmService] now is 2009/03/10 22:21:35 UTC isDate=0
[calAlarmService] adding alarm timeout (25000) ...

After snoozing the alarm for 1 minute:

[calAlarmService] considering alarm for item: New Event alarm time: 2009/03/10 22:22:00 UTC isDate=0 snooze time: 2009/03/10 22:23:08 UTC isDate=0
[calAlarmService] now is 2009/03/10 22:22:08 UTC isDate=0
[calAlarmService] alarm is in the future.
[calAlarmService] adding alarm timeout (60000) ...
(Reporter)

Comment 2

10 years ago
Posted image Screenshot
After more investigation, I think it's a display problem, not a functional problem.  I recently set my default snooze time to 15 minutes in Lightning's options.  The attached screenshot shows that I can see the 1 but not the 5 because I use Courier New in "Windows Control Panel > Display > Appearance > Advanced > Message Text".

This explains why I expected it to snooze for one minute but it actually snoozed for 15 minutes.
(Reporter)

Comment 3

10 years ago
Note:  I use 120 DPI (instead of the default of 96 DPI), if that matters.
(Assignee)

Comment 4

10 years ago
In case it only a display issue: This patch increases the textbox width from 1 to 3 characters (the same width as used in the preference dialog).
Attachment #366901 - Flags: review?(philipp)
(Reporter)

Comment 5

10 years ago
> Created an attachment (id=366901) [details]
> increase textbox width from 1 to 3

That fixes it on my computer, Stefan -- thanks.
(Assignee)

Updated

10 years ago
Severity: major → normal
Summary: Reminders snooze for fifteen minutes instead of one → too small textbox for custom snooze time in reminder dialog causes confusion what snooze time is uses
Attachment #366901 - Flags: review?(philipp) → review+
Argh, I need to get used to you having checking privs. Too late this time :-)

Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/19c3bf5faa58>

-> FIXED
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
OS: Windows XP → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Assignee: nobody → ssitter
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.