Sendchange for hg relauto triggers branch builds

RESOLVED FIXED

Status

Release Engineering
General
P2
normal
RESOLVED FIXED
9 years ago
5 years ago

People

(Reporter: nthomas, Assigned: bhearsum)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
The --branch=releases/mozilla-1.9.1 part of doing a sendchange to start the automation also triggers all the build/unit/leak builders (it matches their branch). We don't see this in staging because you have to use users/stage-ffxbld/mozilla-1.9.1 there to act on the dummy repo.

IIRC we use the branch for the Mercurial() operation in ReleaseBuildFactory (via MercurialBuildFactory), which is shared with the dep builds. Perhaps isHgPollerTriggered (or an analogue for sendchange) can help here.
(Assignee)

Comment 1

9 years ago
Nick, I'm having trouble reproducing this behaviour with a test Buildbot...are you sure there weren't changes being landed around the same time? (I hope not!). I'm going to try and dig up older logs in meantime...
(Assignee)

Comment 2

9 years ago
I found the problem, patch incoming.
Assignee: nobody → bhearsum
Priority: -- → P2
(Assignee)

Comment 3

9 years ago
Created attachment 366904 [details] [diff] [review]
fix MozScheduler to pass along arguments properly

Looks like MozScheduler passes fileIsImportant=None and properties={} down to Scheduler, instead of passing the arguments it was passed. This patch fixes that.
Attachment #366904 - Flags: review?(catlee)
Attachment #366904 - Flags: review?(catlee) → review+
Comment on attachment 366904 [details] [diff] [review]
fix MozScheduler to pass along arguments properly

doh, can't believe I wrote that code.
(Assignee)

Comment 5

9 years ago
Comment on attachment 366904 [details] [diff] [review]
fix MozScheduler to pass along arguments properly

changeset:   214:efb85303e890
Attachment #366904 - Flags: checked‑in+ checked‑in+
(Assignee)

Comment 6

9 years ago
buildbot master has been reconfig'ed for this.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.