Closed Bug 482662 Opened 16 years ago Closed 15 years ago

Firefox creates a $HOME/Desktop directory automatically whenever the "Preferences" tab is opened

Categories

(Toolkit :: Downloads API, defect)

x86_64
Linux
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 434327

People

(Reporter: spamific, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.7) Gecko/2009030719 Firefox/3.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.7) Gecko/2009030719 Firefox/3.0.7

When configured to save files in $HOME/desktop, firefox still insists on creating the $HOME/Desktop folder every time the preferences tab is opened. It also creates this folder whenever a download is initiated if the "Always ask me where to save files" checkbox is clicked.

Reproducible: Always

Steps to Reproduce:
1. Delete ~/Desktop
2. Open the Preferences tab
3. Look at the home folder
Actual Results:  
~/Desktop will be recreated

Expected Results:  
No new directories should be created.

It's absurd to assume a user wants a certain directory to be automatically created every time a menu is opened, without any additional input from the user. It's even more absurd that this still happens when "Desktop" doesn't exist in about:config.
Component: File Handling → Download Manager
Product: Firefox → Toolkit
QA Contact: file.handling → download.manager
Whiteboard: dupeme
Could someone with permission to edit things mark this as a duplicate of #434327?
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.